summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-27 19:23:29 -0500
committerMichał Górny <mgorny@gentoo.org>2018-04-29 12:29:48 +0200
commitdcfa42ebd72fbda1c401cb97c4a30fa7070c8c10 (patch)
tree73e5d16b704c45a3b49ffc324cb3f89ae9044741 /dev-python/python-ldap
parentdev-python/ws4py: git-2->git-r3 (diff)
downloadgentoo-dcfa42ebd72fbda1c401cb97c4a30fa7070c8c10.tar.gz
gentoo-dcfa42ebd72fbda1c401cb97c4a30fa7070c8c10.tar.bz2
gentoo-dcfa42ebd72fbda1c401cb97c4a30fa7070c8c10.zip
dev-python/python-ldap: git-2->git-r3
Closes: https://bugs.gentoo.org/458558 Closes: https://github.com/gentoo/gentoo/pull/8176 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.19-r1.ebuild9
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.32.ebuild12
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild26
3 files changed, 32 insertions, 15 deletions
diff --git a/dev-python/python-ldap/python-ldap-2.4.19-r1.ebuild b/dev-python/python-ldap/python-ldap-2.4.19-r1.ebuild
index f727a2ec88fc..3de4a5a0d0a3 100644
--- a/dev-python/python-ldap/python-ldap-2.4.19-r1.ebuild
+++ b/dev-python/python-ldap/python-ldap-2.4.19-r1.ebuild
@@ -11,11 +11,16 @@ inherit distutils-r1 multilib
DESCRIPTION="Various LDAP-related Python modules"
HOMEPAGE="https://www.python-ldap.org/en/latest/
https://pypi.org/project/python-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
+fi
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
IUSE="doc examples sasl ssl"
# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
diff --git a/dev-python/python-ldap/python-ldap-2.4.32.ebuild b/dev-python/python-ldap/python-ldap-2.4.32.ebuild
index c43b6bc092ca..623b5213fb84 100644
--- a/dev-python/python-ldap/python-ldap-2.4.32.ebuild
+++ b/dev-python/python-ldap/python-ldap-2.4.32.ebuild
@@ -10,11 +10,16 @@ inherit distutils-r1 multilib
DESCRIPTION="Various LDAP-related Python modules"
HOMEPAGE="https://www.python-ldap.org/en/latest/
https://pypi.org/project/python-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+fi
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
IUSE="examples sasl ssl"
# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
@@ -26,7 +31,8 @@ RDEPEND=">net-nds/openldap-2.4.11
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
RDEPEND+=" !dev-python/pyldap"
python_prepare_all() {
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index 468171efb88c..ee6ebf08e0ea 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -1,33 +1,39 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-# pypy: bug #458558 (wrong linker options due to not respecting CC)
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1 git-2 multilib
+inherit distutils-r1
DESCRIPTION="Various LDAP-related Python modules"
HOMEPAGE="https://www.python-ldap.org/en/latest/
https://pypi.org/project/python-ldap/"
-EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+fi
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS=""
IUSE="doc examples sasl ssl"
# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
# python team: Please do not remove python-ldap-2.3.9 from the tree.
RDEPEND=">=net-nds/openldap-2.4
dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}] )"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ )
+"
RDEPEND+=" !dev-python/pyldap"
python_prepare_all() {