summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 07:39:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 07:39:27 +0200
commit30995f6904c4458a95a382c28c220c38f63e9456 (patch)
tree89b9953c10e4eb318e789442efa9870d7b28300a /dev-python/python-evdev
parentgames-util/lutris: Revert "enable py3.11" (diff)
downloadgentoo-30995f6904c4458a95a382c28c220c38f63e9456.tar.gz
gentoo-30995f6904c4458a95a382c28c220c38f63e9456.tar.bz2
gentoo-30995f6904c4458a95a382c28c220c38f63e9456.zip
dev-python/python-evdev: Revert "enable py3.11"
Reverts: 53e0f5cb69d174d980867e4a0218abc9210e6479 Closes: https://bugs.gentoo.org/858476 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-evdev')
-rw-r--r--dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch14
-rw-r--r--dev-python/python-evdev/python-evdev-1.5.0.ebuild7
2 files changed, 1 insertions, 20 deletions
diff --git a/dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch b/dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch
deleted file mode 100644
index 1f516c79acb2..000000000000
--- a/dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/evdev/eventio_async.py b/evdev/eventio_async.py
-index 77542a4..68225c3 100644
---- a/evdev/eventio_async.py
-+++ b/evdev/eventio_async.py
-@@ -85,8 +85,7 @@ class ReadIterator(object):
- def __aiter__(self):
- return self
-
-- @asyncio.coroutine
-- def __anext__(self):
-+ async def __anext__(self):
- future = asyncio.Future()
- try:
- # Read from the previous batch of events.
diff --git a/dev-python/python-evdev/python-evdev-1.5.0.ebuild b/dev-python/python-evdev/python-evdev-1.5.0.ebuild
index 3d0340816d88..a1df11de9086 100644
--- a/dev-python/python-evdev/python-evdev-1.5.0.ebuild
+++ b/dev-python/python-evdev/python-evdev-1.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -21,11 +21,6 @@ KEYWORDS="amd64 ~arm x86"
distutils_enable_tests pytest
-PATCHES=(
- # https://github.com/gvalkov/python-evdev/pull/174
- "${FILESDIR}/${P}-python311.patch"
-)
-
EPYTEST_DESELECT=(
tests/test_uinput.py
)