summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-09 18:51:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-09 19:38:12 -0400
commitac46e7983d9a3bf45eddc9f45b4c0d86d4bae63b (patch)
treeb59b1e7e96321c37a357e405a8aabf510f9d6975 /dev-python/pytest-xvfb
parentdev-python/pytest-xvfb: add myself as a maintainer (diff)
downloadgentoo-ac46e7983d9a3bf45eddc9f45b4c0d86d4bae63b.tar.gz
gentoo-ac46e7983d9a3bf45eddc9f45b4c0d86d4bae63b.tar.bz2
gentoo-ac46e7983d9a3bf45eddc9f45b4c0d86d4bae63b.zip
dev-python/pytest-xvfb: tidy and switch to pypi.eclass
wrt subprocess, this is due to pytest.ini being missing in the pypi tarball -- kind of trivial so can just add it rather than stick to github and add the missing .gh. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/Manifest2
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild19
2 files changed, 10 insertions, 11 deletions
diff --git a/dev-python/pytest-xvfb/Manifest b/dev-python/pytest-xvfb/Manifest
index 2132937334bb..20b243acc881 100644
--- a/dev-python/pytest-xvfb/Manifest
+++ b/dev-python/pytest-xvfb/Manifest
@@ -1 +1 @@
-DIST pytest-xvfb-2.0.0.tar.gz 6855 BLAKE2B 338802ccbf5fc0c9ab3fccd7c172b31867cc86869dfc50dbb30daf396ecd9865e71c6486cc96c2485e2d5b6195dc2eff83a033864f88e1b2c64a3937b6b48c84 SHA512 42c2119b2c529a45b5de9f8ac2781306cfb9f00c1d0e0e9045ed40ccb7260cb6f400683802ab845ce2481dcadfcef007c8417a481e9c04f14ee1bdc68244d391
+DIST pytest-xvfb-2.0.0.tar.gz 6575 BLAKE2B 7ef37f2d4a1a9d7211a248e67d325f0b722a0a046e6e57ae24cac1b68ead6d11988d49810e15fc41d9a05082d9c318f7569a00ac7574e1a8ee00e76c842cf83b SHA512 de5a98290bfe083cadc732c36a1c5af99b0d618853f8da9a1acd0f0f11a170c54025667c0f13bc0f4ac2657b139306e16d0b3faf00bfdde37eb3df7fb14367ae
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
index ed4dc6f4834e..b3c16258b82c 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
@@ -3,27 +3,26 @@
EAPI=8
-PYTHON_REQ_USE="tk"
-PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 pypi
-DESCRIPTION="A pytest plugin to run Xvfb for tests"
+DESCRIPTION="Pytest plugin to run Xvfb for tests"
HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
-SRC_URI="https://github.com/The-Compiler/pytest-xvfb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
RDEPEND="
- >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
- >=dev-python/pyvirtualdisplay-1.3[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]
-"
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]"
distutils_enable_tests pytest
python_test() {
- epytest -p xvfb
+ epytest -p xvfb --runpytest=subprocess
}