summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-06 06:21:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-06 06:26:41 +0100
commitd6df1c1a4593356c0c33dfa67007c53e7defb2e2 (patch)
tree9a77c3631d66b7f63894e00397e7e512f0555292 /dev-python/pytest-xprocess
parentdev-python/sphinx-autodoc-typehints: Bump to 1.20.0 (diff)
downloadgentoo-d6df1c1a4593356c0c33dfa67007c53e7defb2e2.tar.gz
gentoo-d6df1c1a4593356c0c33dfa67007c53e7defb2e2.tar.bz2
gentoo-d6df1c1a4593356c0c33dfa67007c53e7defb2e2.zip
dev-python/pytest-xprocess: Bump to 0.22.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 1c576e6edb2b..7ff503cb3067 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.21.0.tar.gz 30601 BLAKE2B c487b6223306c8a96ea2c4f99763ab8e59ea1db908b2ed93280fa3e2805794798b4555c3d07c730f911702712371bb390780709caa9eb6663451367f58b9781c SHA512 72f8db45a11cffb65302379c1690ef5ad9d71a1aa40b7fd03e1231f7ad0c0413638f7d2155f5b366d2d623399512759d8ffdac8591eb24b77562f9b1f584ed74
+DIST pytest-xprocess-0.22.2.tar.gz 31346 BLAKE2B 07b9fdfea2ecd3d3aaf4115c2f7ecd41c864b4490694cedc54460d0f16397ebdda0ac88fd9bd1613dcaec1cb9c36571b8ab2febc8d151f8f6c4e19fe3abd0821 SHA512 2051be110dfda8063c31bb9555bff569f5d7a1332a62f8ce57fd799dfc7d8551ba1227df12f44fccc1ec62d9fcc0face104a77c9c5cc1abb583b74cd1d8a9ff7
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild
new file mode 100644
index 000000000000..f275eaaf7297
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest