summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-24 06:08:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-24 06:08:32 +0100
commit71ecdfe02063d43c31aedf3544cc0c2777127d06 (patch)
treeef8412f0ac6c1cb537cdc7b4fcaa5254ddf77ada /dev-python/pytest-param-files
parentapp-admin/awscli: Bump to 1.27.78 (diff)
downloadgentoo-71ecdfe02063d43c31aedf3544cc0c2777127d06.tar.gz
gentoo-71ecdfe02063d43c31aedf3544cc0c2777127d06.tar.bz2
gentoo-71ecdfe02063d43c31aedf3544cc0c2777127d06.zip
dev-python/pytest-param-files: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-param-files')
-rw-r--r--dev-python/pytest-param-files/Manifest1
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
index d690b091c1d8..a26d28bfe61e 100644
--- a/dev-python/pytest-param-files/Manifest
+++ b/dev-python/pytest-param-files/Manifest
@@ -1 +1,2 @@
DIST pytest-param-files-0.3.4.gh.tar.gz 6882 BLAKE2B e2e96bd2cf7b8676f92eeb7821ef76f1f82bb066210170ed4d04a16a7fb3ce346bcd63688ef9d46118c03fd74812fd821fff0414565befb8c558d03d15af2945 SHA512 2df6fe798aab743fdbf892b88ee1d09c554119429167e85bccb87e4ae9d487f8ab5a66c4157827500e8a5d2930277c7490348f6c38f23243e421d5449bde2df5
+DIST pytest-param-files-0.3.5.gh.tar.gz 7245 BLAKE2B 2a67c5ee30d6efb6b7ca7e3272c19c05dda460167cb1709693560ffe06b0ae39ae1b93fc5d6375f4e9cda21e3e02051424789afee55d201cfe070be8a05642ec SHA512 e80eddba2934fe5a6b68645cae243afa936ea3362a29d0b8a8ae4e11229ffb877f1ace9f41ac96d182d5787740fa76af8b106069feb95a7cab1ecc6f8d1088f9
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild
new file mode 100644
index 000000000000..06df570c3e27
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest