summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-24 08:06:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-24 09:01:53 +0200
commite5c01250e4989db923b0c7724bfac2dda6158c14 (patch)
tree9a00f85a269572a1832930501509f18e26088bd7 /dev-python/pytest-forked
parentdev-python/asgiref: Bump to 3.7.0 (diff)
downloadgentoo-e5c01250e4989db923b0c7724bfac2dda6158c14.tar.gz
gentoo-e5c01250e4989db923b0c7724bfac2dda6158c14.tar.bz2
gentoo-e5c01250e4989db923b0c7724bfac2dda6158c14.zip
dev-python/pytest-forked: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.6.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
index cccc7f751ac1..3c55c44a4c2e 100644
--- a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
inherit distutils-r1 pypi
@@ -32,5 +32,15 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
+ [[ ${PV} != 1.6.0 ]] && die "Recheck the deselect, please"
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # failing due to warnings coming from pytest
+ # https://github.com/gentoo/gentoo/pull/31151
+ testing/test_xfail_behavior.py::test_xfail
+ )
+ fi
+
epytest -p no:flaky
}