summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-09-14 18:35:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:21 +0300
commitaec083f0f4b646993e3d159af9ebee2cd990f31e (patch)
tree0f43adb7fa9be5ed48c5cbe06a4bdc8daeb9ee42 /dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
parentdev-python/spyder-terminal: cleanup old (diff)
downloadgentoo-aec083f0f4b646993e3d159af9ebee2cd990f31e.tar.gz
gentoo-aec083f0f4b646993e3d159af9ebee2cd990f31e.tar.bz2
gentoo-aec083f0f4b646993e3d159af9ebee2cd990f31e.zip
dev-python/pytest-datadir: plugin for manipulating test dirs and files
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild')
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
new file mode 100644
index 000000000000..4410dfb88542
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="https://github.com/gabrielcnr/pytest-datadir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install
+
+ # Do not install license to /usr
+ rm "${D}/usr/LICENSE" || die
+}