summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-08 21:18:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-15 11:43:52 -0400
commit17686fcf42f5d7bcfc9fc256431b5eb6b4367efc (patch)
tree42ddf7d448ff447d31014312755b4c98b4fd1181 /dev-python/pytest-bdd
parentdev-python/parse_type: initial 0.5.2 import (diff)
downloadgentoo-17686fcf42f5d7bcfc9fc256431b5eb6b4367efc.tar.gz
gentoo-17686fcf42f5d7bcfc9fc256431b5eb6b4367efc.tar.bz2
gentoo-17686fcf42f5d7bcfc9fc256431b5eb6b4367efc.zip
dev-python/pytest-bdd: initial 4.1.0 import
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/metadata.xml13
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
new file mode 100644
index 000000000000..6a2dda084830
--- /dev/null
+++ b/dev-python/pytest-bdd/Manifest
@@ -0,0 +1 @@
+DIST pytest-bdd-4.1.0.tar.gz 61079 BLAKE2B 3bf7863b7244e0fa02de48f3c8d113427c9a9d546d1a5d95dbc025bcdf0bd60931fac55d7328c96a3b29b8b15da833c85c089cee19ee4f8a2bc639dd1b3c4e59 SHA512 54ce5ae2f7b3deff7d436d42f80fc47892707eb1e6e76469dda9753ff0b2d727bb47b5be300eadccadd87838aee43130fec5dff6441353eb07c0787c84d55afa
diff --git a/dev-python/pytest-bdd/metadata.xml b/dev-python/pytest-bdd/metadata.xml
new file mode 100644
index 000000000000..e5bcfe846403
--- /dev/null
+++ b/dev-python/pytest-bdd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-bdd</remote-id>
+ <remote-id type="pypi">pytest-bdd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
new file mode 100644
index 000000000000..c61e3a82d36c
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/glob2[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+EPYTEST_DESELECT=(
+ # result varies depending on current output terminal width
+ tests/feature/test_gherkin_terminal_reporter.py::test_verbose_mode_should_preserve_displaying_regular_tests_as_usual
+)