summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-12 16:52:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-12 16:52:50 +0100
commit3bddbb1780285843ba1e891ee8e2dbb5fe086032 (patch)
treed22d38eefad6d34cafbd966e8da1eae9e11eac35 /dev-python/pyte/pyte-0.8.2.ebuild
parentdev-python/textX: Remove old (diff)
downloadgentoo-3bddbb1780285843ba1e891ee8e2dbb5fe086032.tar.gz
gentoo-3bddbb1780285843ba1e891ee8e2dbb5fe086032.tar.bz2
gentoo-3bddbb1780285843ba1e891ee8e2dbb5fe086032.zip
dev-python/pyte: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyte/pyte-0.8.2.ebuild')
-rw-r--r--dev-python/pyte/pyte-0.8.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyte/pyte-0.8.2.ebuild b/dev-python/pyte/pyte-0.8.2.ebuild
new file mode 100644
index 000000000000..73d0dbf74b23
--- /dev/null
+++ b/dev-python/pyte/pyte-0.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="
+ https://pypi.org/project/pyte/
+ https://github.com/selectel/pyte/
+"
+SRC_URI="
+ https://github.com/selectel/pyte/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # run pytest directly for tests
+ sed -i '/setup_requires/d' setup.py || die
+ distutils-r1_python_prepare_all
+}