summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pysvn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/Manifest2
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.10-respect_flags.patch95
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.9-respect_flags.patch96
-rw-r--r--dev-python/pysvn/metadata.xml5
-rw-r--r--dev-python/pysvn/pysvn-1.7.10.ebuild59
-rw-r--r--dev-python/pysvn/pysvn-1.7.9.ebuild59
6 files changed, 316 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
new file mode 100644
index 000000000000..7af541054db7
--- /dev/null
+++ b/dev-python/pysvn/Manifest
@@ -0,0 +1,2 @@
+DIST pysvn-1.7.10.tar.gz 352631 SHA256 cb8a7eca9fd5d077f4b086c79cc1115a2f38a37979eee836ff258b4da0aee517 SHA512 3404ce53f974ff91a7eecea29176f6b71f1dbb37a716880dfd3d2961d4c6e0c81f87aa46308994d4f7ed6a6cbca7f7451753e1de43ce95fef4443fc5f70ff3aa WHIRLPOOL 99ac425ad2e19355521c73947cf33b2c5bff0023af686d699fdfcd7abc8c5f965974c9762b0dbd3ae3cddfc833e35ac549af1de54ca2472d1354a8fa126e8c36
+DIST pysvn-1.7.9.tar.gz 352320 SHA256 8a58ea6405e5f5ffd0850fc5ed6bc29a93b3573da099293f49ef3241e5be1692 SHA512 966f9b57f63abc68d82a0f0f0d710d3109c2bd515eb0b0dacdca140b0db32154c802d27b4f79062da19f0d18ff6332b729c6f9c06e0a74742161a00b74bef7aa WHIRLPOOL 53f27a30ce97b723fe0d1a8540221e25e593fc00789eab7b6e2814f3ffe3ff8f485523ad7fe3bff7c1b5d101fb87d694a1c18111d2523895835ea72ea1ee6aab
diff --git a/dev-python/pysvn/files/pysvn-1.7.10-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.7.10-respect_flags.patch
new file mode 100644
index 000000000000..18c7ea630dcf
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.7.10-respect_flags.patch
@@ -0,0 +1,95 @@
+diff -ur pysvn-1.7.9.orig/Source/setup_configure.py pysvn-1.7.9/Source/setup_configure.py
+--- Source/setup_configure.py 2014-02-02 22:19:59.000000000 +0800
++++ Source/setup_configure.py 2014-08-15 08:15:44.676746371 +0800
+@@ -848,8 +848,8 @@
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -975,8 +975,8 @@
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
+- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
++ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
++ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % pycxx_version,
+@@ -1031,11 +1031,11 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1047,7 +1047,7 @@
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
++ '$(CXXFLAGS) ',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1073,13 +1073,12 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+- '-framework Security '
+- '%(LDLIBS)s' )
++ '-framework Security' )
+
+ class UnixCompilerGCC(CompilerGCC):
+ def __init__( self, setup ):
+@@ -1139,11 +1138,11 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1154,6 +1153,7 @@
+ self._addVar( 'PYTHON_ARCH_SPECIFIC_INC', distutils.sysconfig.get_python_inc( True ) )
+
+ py_cflags_list = [
++ '$(CXXFLAGS)',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1171,7 +1171,7 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/files/pysvn-1.7.9-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.7.9-respect_flags.patch
new file mode 100644
index 000000000000..7f1c35e59cb3
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.7.9-respect_flags.patch
@@ -0,0 +1,96 @@
+diff -ur pysvn-1.7.9.orig/Source/setup_configure.py pysvn-1.7.9/Source/setup_configure.py
+--- Source/setup_configure.py 2014-02-02 22:19:59.000000000 +0800
++++ Source/setup_configure.py 2014-08-15 08:15:44.676746371 +0800
+@@ -848,8 +848,8 @@
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -975,8 +975,8 @@
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
+- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
++ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
++ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % pycxx_version,
+@@ -1031,12 +1031,12 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-no-long-double '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1048,7 +1048,7 @@
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
++ '$(CXXFLAGS) ',
+ '-no-long-double',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+@@ -1075,13 +1075,12 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+- '-framework Security '
+- '%(LDLIBS)s' )
++ '-framework Security' )
+
+ class UnixCompilerGCC(CompilerGCC):
+ def __init__( self, setup ):
+@@ -1141,11 +1140,11 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1156,6 +1155,7 @@
+ self._addVar( 'PYTHON_ARCH_SPECIFIC_INC', distutils.sysconfig.get_python_inc( True ) )
+
+ py_cflags_list = [
++ '$(CXXFLAGS)',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1173,7 +1173,7 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/metadata.xml b/dev-python/pysvn/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/pysvn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pysvn/pysvn-1.7.10.ebuild b/dev-python/pysvn/pysvn-1.7.10.ebuild
new file mode 100644
index 000000000000..1470a49a5b9f
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-6.2.0[${PYTHON_USEDEP}]
+ <dev-vcs/subversion-1.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-respect_flags.patch )
+
+python_prepare() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
+ sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
+}
+
+python_configure() {
+ cd Source || die
+ # all config options from 1.7.6 are all already set
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/ )
+ use examples && local EXAMPLES=( Examples/Client/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pysvn/pysvn-1.7.9.ebuild b/dev-python/pysvn/pysvn-1.7.9.ebuild
new file mode 100644
index 000000000000..6cc28691f2d7
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-6.2.0[${PYTHON_USEDEP}]
+ <dev-vcs/subversion-1.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-respect_flags.patch )
+
+python_prepare() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
+ sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
+}
+
+python_configure() {
+ cd Source || die
+ # all config options from 1.7.6 are all already set
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/ )
+ use examples && local EXAMPLES=( Examples/Client/. )
+ distutils-r1_python_install_all
+}