summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-20 20:08:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-20 20:15:39 +0200
commit45cd2d4dd619a294afdd23d59a02ba36b29edc2f (patch)
tree6a8500e557977d82f48e72dd95553196eea3821f /dev-python/pystache
parentprofiles: update chromium mask (diff)
downloadgentoo-45cd2d4dd619a294afdd23d59a02ba36b29edc2f.tar.gz
gentoo-45cd2d4dd619a294afdd23d59a02ba36b29edc2f.tar.bz2
gentoo-45cd2d4dd619a294afdd23d59a02ba36b29edc2f.zip
dev-python/pystache: Bump to 0.6.1, modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pystache')
-rw-r--r--dev-python/pystache/Manifest1
-rw-r--r--dev-python/pystache/pystache-0.6.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pystache/Manifest b/dev-python/pystache/Manifest
index f75fabc9293b..dafd3e65121b 100644
--- a/dev-python/pystache/Manifest
+++ b/dev-python/pystache/Manifest
@@ -1 +1,2 @@
DIST pystache-0.6.0.tar.gz 78240 BLAKE2B b3ba14090f7969b7d3bd77f6e23bda8007fbf6f750e008585676f48bb1a4bfc520484b2205225477f2d2d625b0d6c1500d875685fa50f87c11b19589b0d45622 SHA512 802e12795c3ae08fbde37c9e266a60478d46d55a42e2fc339389b664edf3c5ebb2e34069546b820789ad48ed9921f4a2b89f82bb37e72e94846eec0a9ba1568c
+DIST pystache-0.6.1.gh.tar.gz 279050 BLAKE2B 2c61ba260764aa4bf62039bfe1f844d34e26adc29af2f1e1d98619892bfabd3151aa1d34c69596389a68f0d84ce994ddf7114c091d42b497a17b300a5aff36cc SHA512 516d286f84d2c77650550365f6b219acb712376f0b7302fff2aba7dee4d64e3d3fc2d781782777dd37093f6debf52f9d2a40b6ed8b65aa5f7025ff762cb5efae
diff --git a/dev-python/pystache/pystache-0.6.1.ebuild b/dev-python/pystache/pystache-0.6.1.ebuild
new file mode 100644
index 000000000000..5c9556870963
--- /dev/null
+++ b/dev-python/pystache/pystache-0.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Updated Python implementation of Mustache templating framework"
+HOMEPAGE="
+ https://github.com/PennyDreadfulMTG/pystache/
+ https://pypi.org/project/pystache/
+"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/PennyDreadfulMTG/pystache.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/PennyDreadfulMTG/pystache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pystache-test || die "Test failed with ${EPYTHON}"
+}