summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-30 17:34:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-30 17:34:50 +0200
commit831b6539afc7b5cdc19a5123b889a6fc1bef36d2 (patch)
tree4186a9ec1831a28d887c11911b0cdefc68c619ba /dev-python/pyside2-tools
parentdev-python/pyside2: add 5.15.14 (diff)
downloadgentoo-831b6539afc7b5cdc19a5123b889a6fc1bef36d2.tar.gz
gentoo-831b6539afc7b5cdc19a5123b889a6fc1bef36d2.tar.bz2
gentoo-831b6539afc7b5cdc19a5123b889a6fc1bef36d2.zip
dev-python/pyside2-tools: add 5.15.14
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyside2-tools')
-rw-r--r--dev-python/pyside2-tools/Manifest1
-rw-r--r--dev-python/pyside2-tools/pyside2-tools-5.15.14.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/pyside2-tools/Manifest b/dev-python/pyside2-tools/Manifest
index e0d57a9d915f..4778a534d869 100644
--- a/dev-python/pyside2-tools/Manifest
+++ b/dev-python/pyside2-tools/Manifest
@@ -1 +1,2 @@
DIST pyside-setup-opensource-src-5.15.13.tar.xz 3585684 BLAKE2B be464e1a4a5e1523dbc214fdb7be7c5679f33835910d6c12ba464104f3582905f22dd3ae05cbfbb0a7b2d29748335e15d3069d25c754364f5abce85b8b6c8855 SHA512 559e1d474e382ec835cdf2bc69eb27113fdb920a96a63ab0ee022c2a9d2141e5919afd566cb82701e4d2130b142aa59fcbfd60db34823a4f03b879eee5d9e3a8
+DIST pyside-setup-opensource-src-5.15.14.tar.xz 3586520 BLAKE2B ef103cf3116af2c1378018d44abf3766fed6ba545d0e5f3ea6f720047a884edc1eac2dbfce4ddd806472f2ac6355166fd0cef5427f1f85e73306544306adf003 SHA512 c6ca15cc3a3051c00519d9ccb64d48977f8e5587938f97205fe96511ec7bca1a67308325bc1d61712475514c2a1b351fbac2c84f5cee923f55eb91869f49acd5
diff --git a/dev-python/pyside2-tools/pyside2-tools-5.15.14.ebuild b/dev-python/pyside2-tools/pyside2-tools-5.15.14.ebuild
new file mode 100644
index 000000000000..ef9cae1f7c5f
--- /dev/null
+++ b/dev-python/pyside2-tools/pyside2-tools-5.15.14.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{10..11} )
+
+LLVM_COMPAT=( 15 )
+
+inherit cmake llvm-r1 python-r1
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="PySide development tools (pyside2-lupdate with support for Python)"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/sources/${PN}"
+
+LICENSE="GPL-2"
+SLOT="5/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-3)*:5"
+
+RDEPEND="${PYTHON_DEPS}
+ =dev-python/shiboken2-${QT_PV}[${PYTHON_USEDEP},${LLVM_USEDEP}]
+ =dev-python/pyside2-${QT_PV}[${PYTHON_USEDEP},${LLVM_USEDEP}]
+ !dev-python/pyside2-tools:0
+"
+DEPEND="${RDEPEND}
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}
+ sys-devel/llvm:${LLVM_SLOT}
+ ')
+"
+
+# the tools conflict with tools from QT
+PATCHES=(
+ "${FILESDIR}/${PN}-5.15.11-no-copy-uic.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ pyside-tools_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=OFF
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ )
+ cmake_src_configure
+ }
+
+ python_foreach_impl pyside-tools_configure
+}
+
+src_compile() {
+ pyside-tools_compile() {
+ cmake_src_compile
+ }
+
+ python_foreach_impl pyside-tools_compile
+}
+
+src_install() {
+ pyside-tools_install() {
+ # This replicates the contents of the PySide6 pypi wheel
+ DESTDIR="${BUILD_DIR}" cmake_build install
+ dobin "${BUILD_DIR}/usr/bin/pyside2-lupdate"
+ python_moduleinto PySide2/scripts
+ python_domodule "${BUILD_DIR}/usr/bin/pyside_tool.py"
+ }
+
+ python_foreach_impl pyside-tools_install
+
+ einstalldocs
+}