summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-12-13 09:55:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-01-06 15:16:01 +0100
commit110980c31c1038679b3055a5dab6f08629414bcd (patch)
treeaf47f21b339b6a0ba73418d1168b61ca41789988 /dev-python/pyroute2
parentdev-python/docutils: dev-python/pillow optfeature (diff)
downloadgentoo-110980c31c1038679b3055a5dab6f08629414bcd.tar.gz
gentoo-110980c31c1038679b3055a5dab6f08629414bcd.tar.bz2
gentoo-110980c31c1038679b3055a5dab6f08629414bcd.zip
dev-python/pyroute2: add 0.7.10
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/34261 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.10.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index 2ebcc8515143..fef21041d7f5 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
+DIST pyroute2-0.7.10.tar.gz 422192 BLAKE2B ee3eb0961537427aa8ec22d38b0e7e2f53f0ce0fe6802ded685fff1b91616b712b014d64b418122d98a29c030021a7414d2a0f71eff7afaa6e15cc432772c503 SHA512 834beeffb7d5436db6668217d3c3593798727996858211ff5a582446be095372a0c979c328ac97fd1485c27b0b56aedf256fc9ff5c74d2ef9665dce09fbd042d
DIST pyroute2-0.7.9.tar.gz 418877 BLAKE2B 0585af297a58d53ba8698f706e50860eba39ab3334e5d2de9b94d15485399f4429da234e0bc22695097fb90782d482283da304af9bd471749039741cde294734 SHA512 23fea1206a1b6345d05e338449414f3757021ec5cc739aed16cc390e48c62f42f6246838942dc1e3015462aba2ac8051936aad4ce6e76d57ff956046396ecd91
diff --git a/dev-python/pyroute2/pyroute2-0.7.10.ebuild b/dev-python/pyroute2/pyroute2-0.7.10.ebuild
new file mode 100644
index 000000000000..58c1cf80ba9a
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2/
+ https://pypi.org/project/pyroute2/
+"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"