summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-17 15:55:07 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-17 19:35:48 +0100
commit5bb01f3cb5bc7ad6c49d0e02d4063098f095c81a (patch)
tree87f2a0bf54b5fe3064b7be8f2e6319ab813a3f09 /dev-python/pypy
parentsys-kernel/gentoo-sources: Remove 4.19.72 as .86 is newer and stable (diff)
downloadgentoo-5bb01f3cb5bc7ad6c49d0e02d4063098f095c81a.tar.gz
gentoo-5bb01f3cb5bc7ad6c49d0e02d4063098f095c81a.tar.bz2
gentoo-5bb01f3cb5bc7ad6c49d0e02d4063098f095c81a.zip
dev-python/pypy: Skip broken tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy')
-rw-r--r--dev-python/pypy/pypy-7.3.0.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/pypy/pypy-7.3.0.ebuild b/dev-python/pypy/pypy-7.3.0.ebuild
index 23373c0fbe6e..255575b2dbe7 100644
--- a/dev-python/pypy/pypy-7.3.0.ebuild
+++ b/dev-python/pypy/pypy-7.3.0.ebuild
@@ -52,6 +52,23 @@ src_prepare() {
eapply -p2 "${WORKDIR}/${PATCHSET}"/0010-use_pyxml.patch
popd > /dev/null || die
+ # this test relies on pypy-c hardcoding correct build time paths
+ sed -i -e 's:test_executable_without_cwd:_&:' \
+ lib-python/2.7/test/test_subprocess.py || die
+ # this one seems to rely on cpython gc handling (?)
+ sed -i -e 's:test_number_of_objects:_&:' \
+ lib-python/2.7/test/test_multiprocessing.py || die
+ # hardcoded assumptions (?)
+ sed -i -e 's:test_alpn_protocols:_&:' \
+ -e 's:test_default_ecdh_curve:_&:' \
+ lib-python/2.7/test/test_ssl.py || die
+ # requires Internet
+ sed -i -e '/class NetworkedTests/i@unittest.skip("Requires networking")' \
+ lib-python/2.7/test/test_ssl.py || die
+ # TODO: investigate (sandbox?)
+ sed -i -e 's:test__copy_to_each:_&:' \
+ lib-python/2.7/test/test_pty.py || die
+
eapply_user
}