summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-04 07:00:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-04 07:13:11 +0200
commit277c9deae7b912d498bf12dbffeb7ba0aab8a87b (patch)
tree05e3a4612242168fc112b3db20aa7c920579ce2b /dev-python/pyproject-fmt
parentdev-python/pyproject-fmt-rust: Bump to 1.1.5 (diff)
downloadgentoo-277c9deae7b912d498bf12dbffeb7ba0aab8a87b.tar.gz
gentoo-277c9deae7b912d498bf12dbffeb7ba0aab8a87b.tar.bz2
gentoo-277c9deae7b912d498bf12dbffeb7ba0aab8a87b.zip
dev-python/pyproject-fmt: Bump to 2.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.1.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 8419dd540e39..419aa2222678 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1 +1,2 @@
DIST pyproject_fmt-2.1.3.tar.gz 9016 BLAKE2B 742d29283f883f36a6705b74613455932057c508bb98c61d245254fca5d35c31333d01e1047f3c3c4fe46c41ea0633d6a491f59c9633770dd5fb5ee9b696f5ed SHA512 3ba7bc939ed555a58c41bc35563fecba4066e95b0fc4d9c0ecf77ed484cbf2ebd8067fb097dabb499d95ddd7be64712961b70b9abb2f147cc6491c3c8ca85877
+DIST pyproject_fmt-2.1.4.tar.gz 9023 BLAKE2B 1a44332ea829efb22d7b561abef1f362f7eb6ca4682586511e4a87c8f26f55a510f2a1f5e065ec21208c04f754dd729133c859f5d388b0af94578c53bab55d1e SHA512 95e4f99c2ded8f69dca4bbca208512ca17e6fc1e7e13a247f2932c7539ff802a4ed6a822c4ffbada749d4eef15aafd7189f85d722e41360b3523c2b633e15d99
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.1.4.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.1.4.ebuild
new file mode 100644
index 000000000000..97bb4cb063b6
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-2.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ ~dev-python/pyproject-fmt-rust-1.1.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest