summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyopenal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyopenal')
-rw-r--r--dev-python/pyopenal/Manifest1
-rw-r--r--dev-python/pyopenal/files/pyopenal-0.1.6-setup.patch20
-rw-r--r--dev-python/pyopenal/metadata.xml5
-rw-r--r--dev-python/pyopenal/pyopenal-0.1.6-r1.ebuild36
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyopenal/Manifest b/dev-python/pyopenal/Manifest
new file mode 100644
index 000000000000..104649ccd67b
--- /dev/null
+++ b/dev-python/pyopenal/Manifest
@@ -0,0 +1 @@
+DIST PyOpenAL-0.1.6.tar.gz 27698 SHA256 94b69cc57fe5e5abe2876865a6e2264d180892e82ac2ed684dc8eaf2cbf1ec5e SHA512 b617781d8253e4ec81fb806709fa5cb0ca3815d11c2fe1b9a74043909bbc3fa57eb8cb0375ad5999c1a7105c5468a75cb7893e186f48e2c440d8b56bb6a87f7b WHIRLPOOL 238f4e65c31972a131858fda02a0858e85af187318a09d5bc5b48d6b68943de1c1eeec5de1715d4124aa49dc2c5efb445bbddadb6cc02c3214e00c23e3d76275
diff --git a/dev-python/pyopenal/files/pyopenal-0.1.6-setup.patch b/dev-python/pyopenal/files/pyopenal-0.1.6-setup.patch
new file mode 100644
index 000000000000..f9ef9f3c0330
--- /dev/null
+++ b/dev-python/pyopenal/files/pyopenal-0.1.6-setup.patch
@@ -0,0 +1,20 @@
+diff -urN PyOpenAL-0.1.6.orig/setup.py PyOpenAL-0.1.6/setup.py
+--- PyOpenAL-0.1.6.orig/setup.py 2006-04-30 11:23:44.000000000 -0400
++++ PyOpenAL-0.1.6/setup.py 2006-06-13 12:15:46.000000000 -0400
+@@ -4,16 +4,6 @@
+ LIBDIRS = ["/usr/lib", "/usr/local/lib"]
+ LIBS = ["openal", "alut"]
+
+-try:
+- openal_version = os.popen("openal-config --version").read()
+- if openal_version[0] == "0":
+- LIBDIRS = ["/usr/lib", "/usr/local/lib"]
+- LIBS = ["openal"]
+-
+-except:
+- print "Warning: error while running 'openal-config --version', using default values..."
+-
+-
+ setup(
+ name = "PyOpenAL",
+ version = "0.1.6",
diff --git a/dev-python/pyopenal/metadata.xml b/dev-python/pyopenal/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pyopenal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pyopenal/pyopenal-0.1.6-r1.ebuild b/dev-python/pyopenal/pyopenal-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..027803fa9437
--- /dev/null
+++ b/dev-python/pyopenal/pyopenal-0.1.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+MY_P="${P/pyopenal/PyOpenAL}"
+
+DESCRIPTION="OpenAL library port for Python"
+HOMEPAGE="http://home.gna.org/oomadness/en/pyopenal/"
+SRC_URI="http://download.gna.org/pyopenal/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-python/pyogg-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyvorbis-1.1[${PYTHON_USEDEP}]
+ media-libs/freealut
+ media-libs/openal"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS CHANGES )
+PATCHES=( "${FILESDIR}/${P}-setup.patch" )
+
+python_compile() {
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile
+}