summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 22:17:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 22:17:23 +0100
commitf7a41b2c222c8942dbd4537a3b88579271dde7b0 (patch)
tree3bdc2ab367eeca052ee61b7ed3179d4651cf16eb /dev-python/pymilter
parentdev-python/pymad: Switch to PEP 517 build (diff)
downloadgentoo-f7a41b2c222c8942dbd4537a3b88579271dde7b0.tar.gz
gentoo-f7a41b2c222c8942dbd4537a3b88579271dde7b0.tar.bz2
gentoo-f7a41b2c222c8942dbd4537a3b88579271dde7b0.zip
dev-python/pymilter: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pymilter')
-rw-r--r--dev-python/pymilter/pymilter-1.0.4-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pymilter/pymilter-1.0.4-r2.ebuild b/dev-python/pymilter/pymilter-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..716df497df76
--- /dev/null
+++ b/dev-python/pymilter/pymilter-1.0.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to sendmail milter API"
+HOMEPAGE="https://github.com/sdgathman/pymilter"
+SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest