summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-09 15:00:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-09 15:08:18 +0200
commit90a9425283de75ca52e20ccc0bec1b8cf8f3e74a (patch)
tree650c1a6aae9cc64c7e23bfd067499b7189d0d8e0 /dev-python/pylast
parentdev-python/pylast: Port to py3.9 (diff)
downloadgentoo-90a9425283de75ca52e20ccc0bec1b8cf8f3e74a.tar.gz
gentoo-90a9425283de75ca52e20ccc0bec1b8cf8f3e74a.tar.bz2
gentoo-90a9425283de75ca52e20ccc0bec1b8cf8f3e74a.zip
dev-python/pylast: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-3.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index bac20fb25183..5332d8b7d5c0 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-3.2.1.tar.gz 39763 BLAKE2B 1162efb68b89e381528b73eb5fb1dd45a15fcf8129b59fcae824ee78f100f6ea523207cda5b689b2fe66628b0aa5db313b5fa2f504b61b3b4ef6b64ccf13ea5b SHA512 e79a258e6f7c8490d98b4b737abae29cf763dcc5520f47dfe9fe7827f3163bc43ad7dc5c25edd1099cb4c4cd3483cdc5014331caba6f8c3cb29fb1394a8bfa3a
+DIST pylast-3.3.0.tar.gz 40209 BLAKE2B 45725d8424a54ac03b53a6c7fe79febb0038c07ee6c2685d7b66f29933f91fb4ea55818be1d02f8fb1126758acd1d9ce3366e8a7d84fe3082b9b3003a9b948b3 SHA512 8b0c089896d7efb37bdf3a701d150b0f94f386715eb73122a4a7618f5b1a514f9f7577e8c7c84eacb36b18e69aa064220403a578d0544344ab11e87e1b46695a
diff --git a/dev-python/pylast/pylast-3.3.0.ebuild b/dev-python/pylast/pylast-3.3.0.ebuild
new file mode 100644
index 000000000000..493a9d11357e
--- /dev/null
+++ b/dev-python/pylast/pylast-3.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}