summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-22 20:52:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-22 21:06:06 +0100
commit4c844e5407fe34fff6af2aef8615d2aef4cf228f (patch)
treeacba3c396104d02962a7eb429b871405df54e06c /dev-python/pyjwt
parentdev-python/keyring: Bump to 21.6.0 (diff)
downloadgentoo-4c844e5407fe34fff6af2aef8615d2aef4cf228f.tar.gz
gentoo-4c844e5407fe34fff6af2aef8615d2aef4cf228f.tar.bz2
gentoo-4c844e5407fe34fff6af2aef8615d2aef4cf228f.zip
dev-python/pyjwt: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 83d65a7066a8..f6338047ad6a 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1 +1,2 @@
DIST PyJWT-1.7.1.tar.gz 41979 BLAKE2B 5604b309838b2dfb2f95e18e291c43703954664aa8acb7439072f002c1c8a1e49ff2c21d907be77a4d2f86e695ec71970d550aad2541252ac85bd7133e300b28 SHA512 70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4
+DIST PyJWT-2.0.0.tar.gz 56981 BLAKE2B e093bf23beb86a287e494018aed6bd6870d5923697b6502e4269f0b991b28c4ea6a53261b88789b0786b59e03b3d4eb763006becf0666921a81d0528c7677af5 SHA512 1831c93f100cd481e2ea80e23ff9f5114806cc493efc1c42ec6ff3ecc07e716d9ba2557b0b66fd8413946d166eebc1a44c453ec5407dfeef0529d222c9187e45
diff --git a/dev-python/pyjwt/pyjwt-2.0.0.ebuild b/dev-python/pyjwt/pyjwt-2.0.0.ebuild
new file mode 100644
index 000000000000..003ac25f08b5
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ find . -name '__pycache__' -prune -exec rm -rf {} + || die
+ find . -name '*.pyc' -delete || die
+
+ # enables coverage, we don't need that
+ rm setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+}