summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyid3lib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyid3lib')
-rw-r--r--dev-python/pyid3lib/Manifest1
-rw-r--r--dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch20
-rw-r--r--dev-python/pyid3lib/files/pyid3lib-0.5.1-py25.patch57
-rw-r--r--dev-python/pyid3lib/metadata.xml8
-rw-r--r--dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild36
-rw-r--r--dev-python/pyid3lib/pyid3lib-0.5.1-r2.ebuild34
6 files changed, 156 insertions, 0 deletions
diff --git a/dev-python/pyid3lib/Manifest b/dev-python/pyid3lib/Manifest
new file mode 100644
index 000000000000..cb87ac6f96ab
--- /dev/null
+++ b/dev-python/pyid3lib/Manifest
@@ -0,0 +1 @@
+DIST pyid3lib-0.5.1.tar.bz2 21207 SHA256 2a7bdd52c24ed0e70e4a2d82c697214c4ab5a70f94ea9e7934df15ca202d1169 SHA512 fee073a7bd87540a186122b477e918b2c3d8a234ea5ebd83207115b9d0503cc22645b93f6702b79a1b41104d0cbcaa3c47900bba27ce52d44195a8f8a6331c57 WHIRLPOOL 35bc8cd5645269d0e7d95043188a4dfb789ed868ee0d6975175daf0de3366dd0b7f6a28f0967d3d9ea9b0f3f2de55dd6d871efdcc4a5ac6e19c2d08601af68b6
diff --git a/dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch b/dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch
new file mode 100644
index 000000000000..04df9e0a6c98
--- /dev/null
+++ b/dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch
@@ -0,0 +1,20 @@
+--- pyid3lib.cc
++++ pyid3lib.cc
+@@ -920,7 +920,7 @@ enum frame_type
+
+ typedef struct
+ {
+- char* name;
++ const char* name;
+ ID3_FrameID fid;
+ frame_type type;
+ } magic_attribute;
+@@ -1030,7 +1030,7 @@ static PyObject* id3_getattr( ID3Object* self, char* attrname )
+ {
+ ID3_Frame* frame;
+ const char* str;
+- char* slash;
++ const char* slash;
+ ID3_Field* fld;
+ int i;
+
diff --git a/dev-python/pyid3lib/files/pyid3lib-0.5.1-py25.patch b/dev-python/pyid3lib/files/pyid3lib-0.5.1-py25.patch
new file mode 100644
index 000000000000..c24cfc97d5ac
--- /dev/null
+++ b/dev-python/pyid3lib/files/pyid3lib-0.5.1-py25.patch
@@ -0,0 +1,57 @@
+--- pyid3lib-0.5.1/pyid3lib.cc.orig 2007-08-08 23:53:08.000000000 +0300
++++ pyid3lib-0.5.1/pyid3lib.cc 2007-08-08 23:53:12.000000000 +0300
+@@ -10,13 +10,19 @@
+ #include <id3/id3lib_frame.h>
+ #include <id3/tag.h>
+
++#if PY_VERSION_HEX < 0x02050000 && !defined(PY_SSIZE_T_MIN)
++typedef int Py_ssize_t;
++#define PY_SSIZE_T_MAX INT_MAX
++#define PY_SSIZE_T_MIN INT_MIN
++#endif
++
+ typedef struct
+ {
+ PyObject_HEAD
+
+ ID3_Tag* tag;
+ ID3_Frame** frames;
+- int size, alloc;
++ Py_ssize_t size, alloc;
+ } ID3Object;
+
+ typedef struct
+@@ -80,13 +86,24 @@
+
+
+ static PySequenceMethods tag_as_sequence = {
++#if PY_VERSION_HEX >= 0x02050000
++ (lenfunc)id3_length,
++#else
+ (inquiry)id3_length,
++#endif
+ NULL,
+ NULL,
++#if PY_VERSION_HEX >= 0x02050000
++ (ssizeargfunc)id3_item,
++ (ssizessizeargfunc)id3_slice,
++ (ssizeobjargproc)id3_ass_item,
++ (ssizessizeobjargproc)id3_ass_slice,
++#else
+ (intargfunc)id3_item,
+ (intintargfunc)id3_slice,
+ (intobjargproc)id3_ass_item,
+ (intintobjargproc)id3_ass_slice,
++#endif
+ (objobjproc)id3_contains,
+ NULL,
+ NULL,
+@@ -824,7 +841,7 @@
+ static ID3_Frame* frame_from_dict( ID3_FrameID fid, PyObject* dict )
+ {
+ char* data;
+- int size;
++ Py_ssize_t size;
+
+ ID3_Field* field;
+ ID3_FieldID flid;
diff --git a/dev-python/pyid3lib/metadata.xml b/dev-python/pyid3lib/metadata.xml
new file mode 100644
index 000000000000..1f09e0ca6c52
--- /dev/null
+++ b/dev-python/pyid3lib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">pyid3lib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild b/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..ffcb0dd8d315
--- /dev/null
+++ b/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Module for manipulating ID3 tags in Python"
+HOMEPAGE="http://pyid3lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="media-libs/id3lib"
+RDEPEND="${DEPEND}"
+
+PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${P}-gcc-4.4.patch"
+ epatch "${FILESDIR}/${P}-py25.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml doc.html || die "dohtml failed"
+}
diff --git a/dev-python/pyid3lib/pyid3lib-0.5.1-r2.ebuild b/dev-python/pyid3lib/pyid3lib-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..11f9710a7f44
--- /dev/null
+++ b/dev-python/pyid3lib/pyid3lib-0.5.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Module for manipulating ID3 tags in Python"
+HOMEPAGE="http://pyid3lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="media-libs/id3lib"
+RDEPEND="${DEPEND}"
+
+HTML_DOCS=( doc.html )
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.4.patch"
+ "${FILESDIR}/${P}-py25.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ append-flags -fno-strict-aliasing
+}