summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 15:31:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 15:36:26 +0200
commit9256661fc329cdaeb4a3b46b00ec2e12eff2aebe (patch)
treeb41bcf67ed1d07fd6f3e9f14eb3467a678e456dc /dev-python/pyhamcrest
parentdev-python/hyperlink: Enable py3.11 (diff)
downloadgentoo-9256661fc329cdaeb4a3b46b00ec2e12eff2aebe.tar.gz
gentoo-9256661fc329cdaeb4a3b46b00ec2e12eff2aebe.tar.bz2
gentoo-9256661fc329cdaeb4a3b46b00ec2e12eff2aebe.zip
dev-python/pyhamcrest: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.0.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.0.3-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..587a165032ce
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="
+ https://github.com/hamcrest/PyHamcrest/
+ https://pypi.org/project/PyHamcrest/
+"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}