summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 05:38:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 05:59:27 +0200
commitc0f61443ad839e797fb761001c03b732a9dd2ca5 (patch)
tree871ec051b2cbd123aceeb942a3a20d7124168264 /dev-python/pyghmi
parentdev-python/ipyparallel: Bump to 8.6.0 (diff)
downloadgentoo-c0f61443ad839e797fb761001c03b732a9dd2ca5.tar.gz
gentoo-c0f61443ad839e797fb761001c03b732a9dd2ca5.tar.bz2
gentoo-c0f61443ad839e797fb761001c03b732a9dd2ca5.zip
dev-python/pyghmi: Bump to 1.5.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.61.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 43f91e73abea..f93b3011178f 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.60.tar.gz 251748 BLAKE2B 8e860847293db5b747144b3f5e21690c898ebc80c5de8c24dac169b38653893c90b80b0820d3acb5309e95e934cb75e8390b9b5f65e08513a1bd0b62ee62fe9f SHA512 a75528fea803ec68ae12f34befc7d95072baa1bffb8a60d62ebccf41b62f5bdbb510d1b11d9f31ddcc82830ebdc3b31ef6d51b5bca16c89be5dd450cd0a1f82e
+DIST pyghmi-1.5.61.tar.gz 252058 BLAKE2B 468805d478f665b1e516f9362c00519a5d82965158f5e829610eff81addf92860d69273f1e4d9708c245e33956a8e239e873b86a37f58c3d65a049bdd1a7a183 SHA512 783491d5ec76568a8c07c85d24e013aa9b532e06269c0c6efcddd6362fc184545fe8ce22c0ac5b447171163c88ec4656cea7435fa517e8dd5dc53b460bf8368e
diff --git a/dev-python/pyghmi/pyghmi-1.5.61.ebuild b/dev-python/pyghmi/pyghmi-1.5.61.ebuild
new file mode 100644
index 000000000000..7b3d2e7d3897
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.61.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest