summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 09:08:37 +0000
committerSam James <sam@gentoo.org>2023-02-17 09:48:19 +0000
commit8b62b8d391bc4eccfc6775132c64e5a90fb63a11 (patch)
treee13e035736b99c607079c880c154ba92ba370e23 /dev-python/pygccxml
parentdev-db/sqlitestudio: fix install with FEATURES=test (diff)
downloadgentoo-8b62b8d391bc4eccfc6775132c64e5a90fb63a11.tar.gz
gentoo-8b62b8d391bc4eccfc6775132c64e5a90fb63a11.tar.bz2
gentoo-8b62b8d391bc4eccfc6775132c64e5a90fb63a11.zip
dev-python/pygccxml: skip pycodestyle tests
Closes: https://bugs.gentoo.org/895074 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild b/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
index 56110eb0d87b..b2466d83a688 100644
--- a/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
+++ b/dev-python/pygccxml/pygccxml-2.2.1-r1.ebuild
@@ -23,3 +23,11 @@ DEPEND="${RDEPEND}"
distutils_enable_tests unittest
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_prepare_all() {
+ # We're not interested in linter tests in Gentoo, needs pycodestyle
+ rm unittests/pep8_tester.py || die
+ sed -i -e '/pep8_tester/d' unittests/test_all.py || die
+
+ distutils-r1_python_prepare_all
+}