summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-03-25 15:48:50 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2024-03-25 15:50:23 +0100
commit57313b5a0994511f60ea73610ebcc535716a07ea (patch)
tree7dc558761f9fc12935b7dba0aae32f41175f69e2 /dev-python/pygccxml
parentmedia-gfx/digikam: add kde-invent upstream metadata (diff)
downloadgentoo-57313b5a0994511f60ea73610ebcc535716a07ea.tar.gz
gentoo-57313b5a0994511f60ea73610ebcc535716a07ea.tar.bz2
gentoo-57313b5a0994511f60ea73610ebcc535716a07ea.zip
dev-python/pygccxml: Fix build of documentation
- drop no longer used import statement - fix module file path Closes: https://bugs.gentoo.org/920767 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch21
-rw-r--r--dev-python/pygccxml/pygccxml-2.4.0.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch b/dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch
new file mode 100644
index 000000000000..ecec89c14ed9
--- /dev/null
+++ b/dev-python/pygccxml/files/pygccxml-2.4.0-doc.patch
@@ -0,0 +1,21 @@
+diff --git a/docs/conf.py b/docs/conf.py
+index 071ebb1..2ccec1f 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -23,7 +23,6 @@ import importlib.metadata
+ # documentation root, use os.path.abspath to make it absolute, like shown here.
+ sys.path.insert(0, os.path.abspath('.') + "/../src")
+
+-from release_utils import utils # nopep8
+
+ # -- General configuration ------------------------------------------------
+
+@@ -284,7 +283,7 @@ def run_apidoc(_):
+ os.path.join(sys.prefix, 'bin', 'sphinx-apidoc'))
+ subprocess.check_call(
+ [cmd_path, '-o', output_path,
+- os.path.abspath(cur_dir + "/../" + module),
++ os.path.abspath(cur_dir + "/../src/" + module),
+ '--separate', '--force', '--module-first', '--doc-project=API'])
+
+
diff --git a/dev-python/pygccxml/pygccxml-2.4.0.ebuild b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
index f93c64023594..114320ffb31d 100644
--- a/dev-python/pygccxml/pygccxml-2.4.0.ebuild
+++ b/dev-python/pygccxml/pygccxml-2.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,7 @@ distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
python_prepare_all() {
eapply -p0 "${FILESDIR}/${PN}-2.4.0-pyproject.patch"
+ eapply "${FILESDIR}/${PN}-2.4.0-doc.patch"
eapply_user
distutils-r1_python_prepare_all