summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-05 16:52:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-05 16:54:39 +0200
commitc14dd96813223577dc89d09f9dc81dd512055dec (patch)
tree68b3f927866e4af84d0fdf65754900787541adad /dev-python/pydevd/pydevd-3.1.0-r1.ebuild
parentdev-libs/iniparser: unkeyword 4.2.2 (diff)
downloadgentoo-c14dd96813223577dc89d09f9dc81dd512055dec.tar.gz
gentoo-c14dd96813223577dc89d09f9dc81dd512055dec.tar.bz2
gentoo-c14dd96813223577dc89d09f9dc81dd512055dec.zip
dev-python/pydevd: Remove py3.10 support, it doesn't compile
Closes: https://bugs.gentoo.org/933602 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydevd/pydevd-3.1.0-r1.ebuild')
-rw-r--r--dev-python/pydevd/pydevd-3.1.0-r1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/pydevd/pydevd-3.1.0-r1.ebuild b/dev-python/pydevd/pydevd-3.1.0-r1.ebuild
index 42e4036ae60c..b4b1cd642945 100644
--- a/dev-python/pydevd/pydevd-3.1.0-r1.ebuild
+++ b/dev-python/pydevd/pydevd-3.1.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{11..12} )
inherit distutils-r1 toolchain-funcs
@@ -112,13 +112,9 @@ python_test() {
)
case ${EPYTHON} in
- python3.10)
- EPYTEST_DESELECT+=(
- tests_python/test_debugger.py::test_frame_eval_limitations
- )
- ;&
python3.11)
EPYTEST_DESELECT+=(
+ tests_python/test_debugger.py::test_frame_eval_limitations
tests_python/test_debugger.py::test_remote_debugger_threads
)
;;