summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-05-15 22:53:08 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-18 13:39:50 +0200
commit234e850db1d2faa5cef1e9511fce4f47fb8c47e2 (patch)
treeec37d5e1c16d1feacb177ed6722729b3b762e40d /dev-python/pycurl
parentdev-python/PySocks: Bump to python 3.10 (diff)
downloadgentoo-234e850db1d2faa5cef1e9511fce4f47fb8c47e2.tar.gz
gentoo-234e850db1d2faa5cef1e9511fce4f47fb8c47e2.tar.bz2
gentoo-234e850db1d2faa5cef1e9511fce4f47fb8c47e2.zip
dev-python/pycurl: Bump to python 3.10 + disable failing tests
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.6.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pycurl/pycurl-7.43.0.6.ebuild b/dev-python/pycurl/pycurl-7.43.0.6.ebuild
index 130987a64a06..6614d8660689 100644
--- a/dev-python/pycurl/pycurl-7.43.0.6.ebuild
+++ b/dev-python/pycurl/pycurl-7.43.0.6.ebuild
@@ -5,7 +5,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
# The selftests fail with pypy, and urlgrabber segfaults for me.
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1 toolchain-funcs
@@ -53,6 +53,10 @@ python_prepare_all() {
sed -e 's:import wheel:raise ImportError:' -i setup.py || die
# these tests are broken with newer versions of bottle
sed -e 's:test.*_invalid_utf8:_&:' -i tests/getinfo_test.py || die
+ # these tests break with newer version of curl, because they rely
+ # on specific error messages
+ rm tests/failonerror_test.py || die
+
distutils-r1_python_prepare_all
}