summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-17 08:14:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-17 08:15:37 +0100
commit66339c284d66f82e6a9d00e960d2ff89981555df (patch)
tree8a0804956fe63be32b7b13acd1c3fd12a7b5c310 /dev-python/pyclipper
parentdev-python/pyclipper: Add GH remote-id (diff)
downloadgentoo-66339c284d66f82e6a9d00e960d2ff89981555df.tar.gz
gentoo-66339c284d66f82e6a9d00e960d2ff89981555df.tar.bz2
gentoo-66339c284d66f82e6a9d00e960d2ff89981555df.zip
dev-python/pyclipper: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyclipper')
-rw-r--r--dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild b/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
index cfe07333d595..545c1fc46ab7 100644
--- a/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
+++ b/dev-python/pyclipper/pyclipper-1.3.0_p4.ebuild
@@ -4,12 +4,16 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
MY_P=${P/_p/.post}
DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
-HOMEPAGE="https://github.com/fonttools/pyclipper"
+HOMEPAGE="
+ https://github.com/fonttools/pyclipper/
+ https://pypi.org/project/pyclipper/
+"
SRC_URI="
https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz
-> ${MY_P}.gh.tar.gz
@@ -28,7 +32,4 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- distutils-r1_src_prepare
- export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
-}
+export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"