summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyclimate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyclimate')
-rw-r--r--dev-python/pyclimate/Manifest1
-rw-r--r--dev-python/pyclimate/metadata.xml20
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild39
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild39
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pyclimate/Manifest b/dev-python/pyclimate/Manifest
new file mode 100644
index 000000000000..f30ce01a473f
--- /dev/null
+++ b/dev-python/pyclimate/Manifest
@@ -0,0 +1 @@
+DIST PyClimate-1.2.2.tar.gz 1417758 SHA256 3ee4aadf3d072270aa179c8b2345f5e2136df91c7237a30540be146d7fda8c94 SHA512 b217991873e99ad147e0f4e05bfa900a60486852a803ed6c224321f6fc1f1b6700ad2ad1d6c7c7f8ed8ec94340220c5277456c98ccb408f0bef6888c0adf018f WHIRLPOOL aae764d8d1c53e18d7d190ff78b3619d979501bc14b4c0ef5d3d94aeb274fa56a271f76d3e51e18c6efe20255b52cb43233f67c6664dcaeab03e2365444bf956
diff --git a/dev-python/pyclimate/metadata.xml b/dev-python/pyclimate/metadata.xml
new file mode 100644
index 000000000000..056e23c1e4fc
--- /dev/null
+++ b/dev-python/pyclimate/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>python</herd>
+<longdescription>
+ A package designed to accomplish some usual tasks during the analysis of
+ climate variability using Python. It provides functions to perform some
+ simple IO operations, operations with COARDS-compliant netCDF files, EOF
+ analysis, SVD and CCA analysis of coupled data sets, some linear digital
+ filters, kernel based probability density function estimation and access
+ to DCDFLIB.C library.
+</longdescription>
+<longdescription lang="ja">
+このパッケージはPython言語を使った気候の変化を分析する必要なタスクを終えるために
+デザインされました。幾つかの単純なI/O操作、COARDS-compliant netCDFファイルの操作
+、EOF解析、カップル・データのSVDとCCA解析、幾つかのリニア・デジタル・フィルター>、カーネル・ベースのプロバビリティ・デンシティ・ファンクション・エスティメーショ
+ンとDCDFLIB.Cライブラリへのアクセス等の機能を提供します。
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild b/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..d2efe9cfda9b
--- /dev/null
+++ b/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit eutils distutils
+
+MY_P="${P/pyclimate/PyClimate}"
+
+DESCRIPTION="Climate Data Analysis Module for Python"
+HOMEPAGE="http://www.pyclimate.org/"
+SRC_URI="http://fisica.ehu.es/jsaenz/pyclimate_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/numpy
+ >=dev-python/scientificpython-2.8
+ >=sci-libs/netcdf-3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ dodoc doc/manual.ps doc/dcdflib_doc/dcdflib* || die
+
+ if use examples; then
+ insinto /usr/share/${PF}
+ doins -r examples test || die
+ fi
+}
diff --git a/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild b/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..1936aec9a18e
--- /dev/null
+++ b/dev-python/pyclimate/pyclimate-1.2.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+MY_P="${P/pyclimate/PyClimate}"
+
+DESCRIPTION="Climate Data Analysis Module for Python"
+HOMEPAGE="http://www.pyclimate.org/"
+SRC_URI="http://fisica.ehu.es/jsaenz/pyclimate_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/scientificpython-2.8[${PYTHON_USEDEP}]
+ >=sci-libs/netcdf-3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+ dodoc doc/manual.ps doc/dcdflib_doc/dcdflib*
+}