summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-18 07:30:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-18 08:02:58 +0200
commitf93fda915141e2b1f92cfb3086adb1d7ea856101 (patch)
tree714923909fbc27526db747c97561a60c0f392992 /dev-python/pybind11
parentwww-servers/gunicorn: Bump to 21.0.1 (diff)
downloadgentoo-f93fda915141e2b1f92cfb3086adb1d7ea856101.tar.gz
gentoo-f93fda915141e2b1f92cfb3086adb1d7ea856101.tar.bz2
gentoo-f93fda915141e2b1f92cfb3086adb1d7ea856101.zip
dev-python/pybind11: Bump to 2.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.11.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 1c327cf38041..eef588c8e9bb 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1 +1,2 @@
DIST pybind11-2.10.4.gh.tar.gz 740622 BLAKE2B 7b2d86e8262581b2cc6dd720b83336206e242ef8ca99b257b01a11141ed8b127d7f35d7d573bc763dd36f2fe8c8ac91766089deb63a76e9c10029c34eec2d6d3 SHA512 7970defbb6d057a44468ed707c80bfa6ef8c9578528fbc084b03aeea20a52dbd681581f82d55ff90af11ee89693379bd79e2ab6603239ba05b0aa8da29dd93c7
+DIST pybind11-2.11.1.gh.tar.gz 756445 BLAKE2B 66ad933ffcd7fd475121f0b7488e13b914cb090d0ed511b96070e2849dcc537fb55e865b72fe06da6c5d1e3ed8e438799c5b0b60cbdc71e5713530174bff3be9 SHA512 ed1512ff0bca3bc0a45edc2eb8c77f8286ab9389f6ff1d5cb309be24bc608abbe0df6a7f5cb18c8f80a3bfa509058547c13551c3cd6a759af708fd0cdcdd9e95
diff --git a/dev-python/pybind11/pybind11-2.11.1.ebuild b/dev-python/pybind11/pybind11-2.11.1.ebuild
new file mode 100644
index 000000000000..7b60bb179887
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.11.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="
+ https://pybind11.readthedocs.io/en/stable/
+ https://github.com/pybind/pybind11/
+ https://pypi.org/project/pybind11/
+"
+SRC_URI="
+ https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+BDEPEND="
+ test? (
+ >=dev-cpp/catch-2.13.5
+ dev-libs/boost
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}