summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-29 18:49:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-29 18:58:35 +0200
commit14e339fb17b7cfa1f696bc875f90661bf529fdb7 (patch)
tree869dad5d2380814fa0374a3a55de497c3a1fe4a4 /dev-python/pyalsa
parentdev-python/pydantic: Remove old (diff)
downloadgentoo-14e339fb17b7cfa1f696bc875f90661bf529fdb7.tar.gz
gentoo-14e339fb17b7cfa1f696bc875f90661bf529fdb7.tar.bz2
gentoo-14e339fb17b7cfa1f696bc875f90661bf529fdb7.zip
dev-python/pyalsa: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyalsa')
-rw-r--r--dev-python/pyalsa/Manifest1
-rw-r--r--dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch27
-rw-r--r--dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch34
-rw-r--r--dev-python/pyalsa/pyalsa-1.2.7-r2.ebuild55
4 files changed, 0 insertions, 117 deletions
diff --git a/dev-python/pyalsa/Manifest b/dev-python/pyalsa/Manifest
index 604a0c75bfa4..701e7513e94f 100644
--- a/dev-python/pyalsa/Manifest
+++ b/dev-python/pyalsa/Manifest
@@ -1,2 +1 @@
DIST pyalsa-1.2.12.tar.bz2 40133 BLAKE2B 50e4cff2d4fccdf8fd62cb379c08f55f8229b20cb51ac8c89c6ba84214663992748fc9c3555b4242457348dfc877280754f1574eaffb8c9cbc4e82d376d6660c SHA512 9073cb9a1fc6ad04bafa368435e45dd6c8506e14f0e594f02f7d2b7e06c72b8af9babf08cfead57a940a9ebde4548edf608196fea56089fe8d1300a04f573151
-DIST pyalsa-1.2.7.tar.bz2 40132 BLAKE2B c100d16bd8c0d9fc6eddcda360f3582c55ed1b143a58a49caf76a62494882952d311271941ce0ecdf57ac934f3564dc922c80e8a5f5742b593341ff4215b700c SHA512 126501fe7b9c006f28e9290bdd3ad907ea9e053b71e21e2c6f0b0beeecdba07b4b557014041b03452f96be690f59f2e647e075487ee87054f21f66df7f39b34b
diff --git a/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch b/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
deleted file mode 100644
index 7f8cf6815d03..000000000000
--- a/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- pyalsa-1.1.6/setup.py
-+++ pyalsa-1.1.6/setup.py
-@@ -70,24 +70,3 @@
- 'alsamixer',
- 'alsaseq'
- ]
--
--uname = os.uname()
--dir = 'build/lib.%s-%s-%s/pyalsa' % (uname[0].lower(), uname[4], sys.version[:3])
--files = os.path.exists(dir) and os.listdir(dir) or []
--for f in SOFILES:
-- path = ''
-- for f2 in files:
-- if f2.startswith(f + '.') and f2.endswith('.so'):
-- path = dir + '/' + f2
-- break
-- if not path or not os.path.exists(path):
-- continue
-- p = 'pyalsa/%s.so' % f
-- print("%s -> %s" % (p, path))
-- try:
-- st = os.lstat(p)
-- if stat.S_ISLNK(st.st_mode):
-- os.remove(p)
-- except:
-- pass
-- os.symlink('../' + path, 'pyalsa/%s.so' % f)
diff --git a/dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch b/dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch
deleted file mode 100644
index f27a7714a986..000000000000
--- a/dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://github.com/alsa-project/alsa-python/issues/9
-https://github.com/alsa-project/alsa-python/pull/10
-https://github.com/alsa-project/alsa-python/commit/cb75f5cdba0a29bdfa43eb56285da4917d2941a9
-
-From cb75f5cdba0a29bdfa43eb56285da4917d2941a9 Mon Sep 17 00:00:00 2001
-From: Francesco Ceruti <ceppofrancy@gmail.com>
-Date: Sat, 4 May 2024 22:16:16 +0200
-Subject: [PATCH] alsaseq: fix seg. fault when accessing `ConstantObject` extra
-
-Closes: https://github.com/alsa-project/alsa-python/pull/10
-Signed-off-by: Francesco Ceruti <ceppofrancy@gmail.com>
-Signed-off-by: Jaroslav Kysela <perex@perex.cz>
---- a/pyalsa/alsaseq.c
-+++ b/pyalsa/alsaseq.c
-@@ -353,18 +353,11 @@ typedef struct {
- } ConstantObject;
-
- #if PY_MAJOR_VERSION < 3
--/* PyInt is fixed size in Python 2 */
- # define CONST_VALUE(x) PyInt_AsLong((PyObject *)x)
--# define CONST_EXTRA(x) (&(x->extra))
- #else
--/* PyLong is variable size in Python 3 */
- # define CONST_VALUE(x) PyLong_AsLong((PyObject *)x)
--# define CONST_EXTRA(x) \
-- ((ConstantExtraFields *)( \
-- ((intptr_t)(&x->extra)) \
-- + abs(Py_SIZE(&x->base)) * Py_TYPE(x)->tp_itemsize \
-- ))
- #endif
-+# define CONST_EXTRA(x) (&(x->extra))
-
- /** alsaseq.Constant type (initialized later...) */
- static PyTypeObject ConstantType;
diff --git a/dev-python/pyalsa/pyalsa-1.2.7-r2.ebuild b/dev-python/pyalsa/pyalsa-1.2.7-r2.ebuild
deleted file mode 100644
index dcd1db533d12..000000000000
--- a/dev-python/pyalsa/pyalsa-1.2.7-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for ALSA library"
-HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
-SRC_URI="https://www.alsa-project.org/files/pub/pyalsa/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-# Needs access to system's alsa configuration/devices
-RESTRICT="test"
-
-DEPEND="
- media-libs/alsa-lib
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.6-no-build-symlinks.patch"
- "${FILESDIR}/${PN}-1.2.7-python3.12.patch"
-)
-
-python_test() {
- cd "${T}" || die
-
- shopt -s nullglob
- local test
- local failed
- for test in "${S}"/test/*.py ; do
- ${EPYTHON} "${test}" || {
- eerror "${test} failed with ${EPYTHON}"
- failed=1
- break
- }
- done
- shopt -u nullglob
-
- if [[ ${failed} -eq 1 ]] ; then
- die "${test} failed with ${EPYTHON}"
- fi
-}