summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-18 12:23:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-18 13:47:42 +0200
commit29f9e56ed0b826463d8a5601679830b494f7ca8b (patch)
tree13a89e12b808b2fed340d44d8e01cca8fd3aa56e /dev-python/pxml
parentprofiles: Mask app-office/akonadi-server[qt5] (diff)
downloadgentoo-29f9e56ed0b826463d8a5601679830b494f7ca8b.tar.gz
gentoo-29f9e56ed0b826463d8a5601679830b494f7ca8b.tar.bz2
gentoo-29f9e56ed0b826463d8a5601679830b494f7ca8b.zip
dev-python/pxml: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pxml')
-rw-r--r--dev-python/pxml/Manifest1
-rw-r--r--dev-python/pxml/pxml-0.2.12.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pxml/Manifest b/dev-python/pxml/Manifest
index fa434adf8cf2..edfdb53f9e02 100644
--- a/dev-python/pxml/Manifest
+++ b/dev-python/pxml/Manifest
@@ -1 +1,2 @@
DIST pxml-0.2.11.tar.gz 21088 SHA256 19edfd55a081fb46066b66fd726691be3416d6f93e80f3d0bb2f2a8d7bacb6c8 SHA512 1b71ca2b5e0e59158f52fbe70ef65f5fc14dec4aec1c7fa79f7fabd8dc33f63f63e70b61ba835d2c21f88c879fa6dd5c4aa7dad97ee49755e4a6844aeceea5e1 WHIRLPOOL 4d170075db8076c0ca94dd1f5ee52f6148c59b1e7cfd07557fe045a31bdf7d9b2f8e1e453ec9643cb4a0b466a7cb1622f02ecf0a8b831d9813a4af27d9f05070
+DIST pxml-0.2.12.tar.gz 21194 SHA256 99604ac9c1b6408f314a57e2e6eb5791220982a7e961168475c682c657ce3c26 SHA512 95c66036d161c1245edfc7924abde9f63e764bfc39037ff2b5d281840e7b306c08091c9845ad4d5738ebe2769f27d90e1b6b226379ee6fd263db323ff629d42b WHIRLPOOL b6de6b1288e8479fa6bc41c2a5b7c6dd917e8ce0988c3bade10cdf78c622f6a9b6cffcf5999cd5a41edd474de834cdc53016dfb5b944d79e09384c6e71576709
diff --git a/dev-python/pxml/pxml-0.2.12.ebuild b/dev-python/pxml/pxml-0.2.12.ebuild
new file mode 100644
index 000000000000..55a3a98c3648
--- /dev/null
+++ b/dev-python/pxml/pxml-0.2.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library and command-line tool to "prettify" and colorize XML"
+HOMEPAGE="https://pypi.python.org/pypi/pxml http://github.com/metagriffin/pxml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}