summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-26 20:31:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-26 20:55:04 +0200
commit2886755110d1700d846d799dd003f073c382837d (patch)
treec1f690413c6017509fe5d2057f426f35396dd85b /dev-python/puremagic
parentdev-python/keyring: Bump to 25.2.0 (diff)
downloadgentoo-2886755110d1700d846d799dd003f073c382837d.tar.gz
gentoo-2886755110d1700d846d799dd003f073c382837d.tar.bz2
gentoo-2886755110d1700d846d799dd003f073c382837d.zip
dev-python/puremagic: Bump to 1.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/puremagic')
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/puremagic-1.22.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
index e60787c0ae9c..0959516923b7 100644
--- a/dev-python/puremagic/Manifest
+++ b/dev-python/puremagic/Manifest
@@ -1 +1,2 @@
DIST puremagic-1.21.gh.tar.gz 296990 BLAKE2B 78709c296ee8599009f07f8fadfaa60957895d1a45d3fd5f12605a54901e2f0ab878abdb4dc121a77d2c4da922b2f5a173d13ef660a2265298716a26da28f293 SHA512 cc2c76a2ddcfacdfce778e565b07692dcd247723aa85c562ba4d8c70992f79a8f13a7bc33f1468ee37298c266d35d76febe2e6164fdc145077d68b05cfa2e1c4
+DIST puremagic-1.22.gh.tar.gz 304145 BLAKE2B 8165ae8527462223255a04c84c3e9f15b76298a8e8ad1f38ae3f92c6e359d514efa543cb290d45d37c2d5aa44a6e082e626cf0ed570c40c905f570b8569f43bf SHA512 d447861e9f7a15f307fdf0ee1e34c5f03304dabb783ba4bfdbfa304fdfa0071b9f51ee9b0a3835417057b9fe4143cf5277a0be451024dc253a88bb94b05b9a99
diff --git a/dev-python/puremagic/puremagic-1.22.ebuild b/dev-python/puremagic/puremagic-1.22.ebuild
new file mode 100644
index 000000000000..e9212eebd43c
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.22.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}