summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-28 06:09:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-28 06:27:48 +0200
commit0d568db33d9f6fc17b03b2177277741eccf952a2 (patch)
tree5c8bd3e4f413d26ea350f414a43ccac99c614aa3 /dev-python/prompt-toolkit
parentdev-python/fonttools: Bump to 4.52.3 (diff)
downloadgentoo-0d568db33d9f6fc17b03b2177277741eccf952a2.tar.gz
gentoo-0d568db33d9f6fc17b03b2177277741eccf952a2.tar.bz2
gentoo-0d568db33d9f6fc17b03b2177277741eccf952a2.zip
dev-python/prompt-toolkit: Bump to 3.0.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest1
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.44.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
index b61f48ebe4b3..8c778bfa0dbb 100644
--- a/dev-python/prompt-toolkit/Manifest
+++ b/dev-python/prompt-toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-3.0.43.tar.gz 425733 BLAKE2B 663b3f675e004de9f2d6dce09320bc0bbd6a47f5a581d5b49bb5fe36f0d3eee2022522eac09dccc5bceaf6227e17abe475f133c53b912b3b84f940877aaa6b9a SHA512 833666da9bc7259eec2ee357cb936001880ac1f88c33a1e346ef5e4b8c3fcd37ff7d7102e590d509b0b0ac1e046fcd9d2a7046857c9e95dc3890f1b70c62544c
+DIST prompt_toolkit-3.0.44.tar.gz 425654 BLAKE2B 48d080ad6cab2ed192284ae376c65b43a500b7c642b9298af6afc109a16ddf53d8242748af772dd556a568356ab4af95bb71dfb36ec345ee9d4904f0de15fa20 SHA512 09202d023e52eae2200e23be1ed9bfa91ce072c1c6970d00d92fe9f0fabfaa4117b9e174b43b9ae041f4e0605c77a990625e51e51925d1ff63a65a10e09734a8
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.44.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.44.ebuild
new file mode 100644
index 000000000000..4efb2ede21df
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.44.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires tree-sitter-languages
+ src/prompt_toolkit/lexers/tree_sitter_test.py
+)