summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:43:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:05 +0200
commit84e1f859533314a4947b69e780dfef587a22ea2a (patch)
treef9aa99d0465de40821559f753ca92f8e1d8f0331 /dev-python/pluginbase
parentdev-python/pipenv: Remove redundant versions (diff)
downloadgentoo-84e1f859533314a4947b69e780dfef587a22ea2a.tar.gz
gentoo-84e1f859533314a4947b69e780dfef587a22ea2a.tar.bz2
gentoo-84e1f859533314a4947b69e780dfef587a22ea2a.zip
dev-python/pluginbase: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluginbase')
-rw-r--r--dev-python/pluginbase/Manifest1
-rw-r--r--dev-python/pluginbase/pluginbase-0.5.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
index 6c342243d2f7..9684ae35d467 100644
--- a/dev-python/pluginbase/Manifest
+++ b/dev-python/pluginbase/Manifest
@@ -1,2 +1 @@
-DIST pluginbase-0.5.tar.gz 41964 BLAKE2B 84fc187b60182f100a9016ac663856b29587e60b5ef5ac9c51fb4ed99666908a77c9817c2dc5fb64e82b807e635bd10beb5ce7644e31e63262736cc667a7b8c2 SHA512 921ddc7dacb6ad63abc90beb1d1d993e7b15c9cfe21e850a5852eb40735436e08b39fd2a6d83e23f641014ee81e718aca147ef1e21b55f94ce04a64ba7780455
DIST pluginbase-1.0.0.tar.gz 41795 BLAKE2B 68d7704b52db39af4f0c2e1f790802eb5f2fd15d91726752605901b3e8a3c736204fad93d96b5dd1a4199586b4d9b42895cbe8290acaed1b4051e8103efb43f9 SHA512 95c3b770980fa5ec745b8d788df29c6219ed6e5af7666f9830d56c6acae01f90831655127bcef69b2dfc423d09429373ae7d4c8b45c76c62a41f909d0747c0a0
diff --git a/dev-python/pluginbase/pluginbase-0.5.ebuild b/dev-python/pluginbase/pluginbase-0.5.ebuild
deleted file mode 100644
index 1269425a52e6..000000000000
--- a/dev-python/pluginbase/pluginbase-0.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Support library for building plugins sytems in Python"
-HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- sed -e "s/, 'sphinx.ext.intersphinx'//" \
- -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- cd tests && PYTHONPATH=.. py.test --tb=native || die "Tests fail with ${EPYTHON}"
-}