summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 09:01:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 09:09:14 +0200
commitf4440f1c27cad05ef5cc30e67a38e0999193b152 (patch)
tree6cf4120e2a1a1f1fd6c38a7642739f070cb228a8 /dev-python/pluggy
parentdev-python/pypng: Bump to 0.0.21 (diff)
downloadgentoo-f4440f1c27cad05ef5cc30e67a38e0999193b152.tar.gz
gentoo-f4440f1c27cad05ef5cc30e67a38e0999193b152.tar.bz2
gentoo-f4440f1c27cad05ef5cc30e67a38e0999193b152.zip
dev-python/pluggy: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-1.0.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index a3ce44c13b1b..37992c1d2beb 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-0.13.1.tar.gz 57962 BLAKE2B aa0a3eec06c988a727bc15511313f12a08bde65da55bcc5e7547a654e3ca8a34c12dfa72166b6a37b524972730f08454b6a0446e071d2710396e868ae3a77151 SHA512 eb747ff341cedacbd90eb20e22ad3d1ddf5588056f14d069f56331f4141a15b7eccaee23ea196d2f4906964ddb77a79b156bbf3ef8c8083e9952c55d13d55f3e
+DIST pluggy-1.0.0.tar.gz 51510 BLAKE2B 8107df9a91a843166a602e7518dd1d4167304464a8cc80180b60b03a2ac803be9b1ba190df9189907addd34a92b93a6b271d3d6b7485aa563203ce733c6a656c SHA512 cf0bcbb4330c24ce473614befa19548f33fb39fa0ad094e1eae786202d7adadc28e16499f80ab96b630091765404ca5c5b6f9a55bc605e03514d8ab50cf9ae00
diff --git a/dev-python/pluggy/pluggy-1.0.0.ebuild b/dev-python/pluggy/pluggy-1.0.0.ebuild
new file mode 100644
index 000000000000..f6228c328efc
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3)"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest