summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-24 19:53:21 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-24 19:56:03 +0100
commit18683eeae63bc305ac31fa7e52d333e1b8c16a98 (patch)
tree809fdd0149ae1bf593f1dc2c95444337bd2727cf /dev-python/pluggy
parentdev-python/sqlglot: Bump to 20.10.0 (diff)
downloadgentoo-18683eeae63bc305ac31fa7e52d333e1b8c16a98.tar.gz
gentoo-18683eeae63bc305ac31fa7e52d333e1b8c16a98.tar.bz2
gentoo-18683eeae63bc305ac31fa7e52d333e1b8c16a98.zip
dev-python/pluggy: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-1.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index 7d94b559f754..7706653701d7 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-1.3.0.tar.gz 63670 BLAKE2B afa28641ec0a93e97fed2a03655c76077d046b05f49c4e584df3486dd007fb20296f61b001664d8cbb50d4400f1132f75d5de932caa1d3f92e349f78158d7ade SHA512 d4dbb449f533649da161d7e49f82da5800dabdace4f7aa239c412290470612a45a3ba3c50cafd7bd9ed26cb3aa14648bfa3ed3f41fc0db9ae9399fd7f5933d5f
+DIST pluggy-1.4.0.tar.gz 65812 BLAKE2B 0a8bff68f1871f0e571105012b0e3961771c6ee34a64711520084d0a951308d192187d01b14136c389b5bc09f127ead1a1f96ebffa7b345d2d5023157c049c43 SHA512 ac21a0c68cfcb9c7c401e5c48404f7447489b75befe8bc8b6e7ea84f24a1c6dbfb3de024577dd9e36ca9f538f9867ef836ba13018e3b8b348bba3e9bbd0c4dfd
diff --git a/dev-python/pluggy/pluggy-1.4.0.ebuild b/dev-python/pluggy/pluggy-1.4.0.ebuild
new file mode 100644
index 000000000000..bb57bffff542
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin and hook calling mechanisms for Python"
+HOMEPAGE="
+ https://pluggy.readthedocs.io/
+ https://github.com/pytest-dev/pluggy/
+ https://pypi.org/project/pluggy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest