summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-10 20:46:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-10 22:10:55 +0100
commitff562a6365ad9f0ec33310812871bd753aeff2c0 (patch)
tree6cb2a06538328b5892786cc9c4e4b76a5c4a9e3c /dev-python/platformdirs
parentdev-python/sphinx-autodoc-typehints: Bump to 1.25.1 (diff)
downloadgentoo-ff562a6365ad9f0ec33310812871bd753aeff2c0.tar.gz
gentoo-ff562a6365ad9f0ec33310812871bd753aeff2c0.tar.bz2
gentoo-ff562a6365ad9f0ec33310812871bd753aeff2c0.zip
dev-python/platformdirs: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-4.0.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 07b4cf57bfdc..a84a9b212b4c 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1 +1,2 @@
DIST platformdirs-3.11.0.tar.gz 19914 BLAKE2B bea0cbb3c840441943aaf93b6c88d34ae93cf9a9bea7b00186ffae6f46a820036883cebf996ee998cee9b4b748ab24fcd88d3d318c418e6f70746769bdb8619f SHA512 a273ea8fc5916bdb94da9cc62ccef60a7247b5a019639aae3be9718626ce59d27d8e62c6552c25a3cdd0e7fb7215c32b6c30f2509a3356623f628f771e92bb56
+DIST platformdirs-4.0.0.tar.gz 19914 BLAKE2B 0ae3f7491f3f1d38561c89312c988b4145c9afb60e3d866cd05bef7e02c6df95d56cb230995de2893c0afd32bd63eb08448e67d5cdd0bdf6f3556ea1a23e2b49 SHA512 28eeb18ab5a52bf60d85ab76c986300d0f69c3bcff9ec18b961b70f97bce4e0d1bd3315b8d97f6b6a41de000b734979c08754780d282695525348342ab9c9931
diff --git a/dev-python/platformdirs/platformdirs-4.0.0.ebuild b/dev-python/platformdirs/platformdirs-4.0.0.ebuild
new file mode 100644
index 000000000000..70e821d796fb
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-4.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}