summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-09 20:27:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-09 20:27:33 +0100
commitfdf6bb6727d96a09cbaad7d899713a3487340818 (patch)
treeb3eaed8c1f1c71e7a4811f571baf816561b958bc /dev-python/platformdirs
parentdev-python/moto: Bump to 3.0.3 (diff)
downloadgentoo-fdf6bb6727d96a09cbaad7d899713a3487340818.tar.gz
gentoo-fdf6bb6727d96a09cbaad7d899713a3487340818.tar.bz2
gentoo-fdf6bb6727d96a09cbaad7d899713a3487340818.zip
dev-python/platformdirs: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-2.5.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 1a519d1a4d7b..b36ccc07a72c 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1 +1,2 @@
DIST platformdirs-2.4.1.gh.tar.gz 20051 BLAKE2B 18fd11f7cae7c81c3615c89468d1deb3ceef3337b4a87a806b245b7bb5a4c14c0eb64fc7cfa06adc2da6150969da3a626da16c1f309f3011a9d4c5d1e4ca1d83 SHA512 d410056207506395c922ecc36c481bcc21f8dd97c69f33dc13580c74d0ea3d1aaa97284b79eed47b723f18c663038874edc5b9c4f4def06d92f1e25f7a8d76b4
+DIST platformdirs-2.5.0.gh.tar.gz 20101 BLAKE2B 420e70bfef15d17f69927809580440a4a9df618be7a93299a963bef236c5f966d0abe88f7bd9bf292109e5ddeb9b87b5615171ea1c70db9c7b2934d8b11fde5d SHA512 a50acf15bc776fdb43f6875055991aa85d5ebe7a931e27c9eada42500305cc1c7892e32687f2f882e850a97748e23dc6f2777f7f54558a32d6a413e35569f6f5
diff --git a/dev-python/platformdirs/platformdirs-2.5.0.ebuild b/dev-python/platformdirs/platformdirs-2.5.0.ebuild
new file mode 100644
index 000000000000..1549e1aa516e
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}