summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-30 05:57:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-30 06:00:52 +0100
commit8c6efa4aaba7b6f438ac18ec60f03e533a6f14f3 (patch)
tree699d7ae9cb3213959c48853b563427aa5d2d00cd /dev-python/pipx
parentapp-arch/xarchiver: Bump to 0.5.4.22 (diff)
downloadgentoo-8c6efa4aaba7b6f438ac18ec60f03e533a6f14f3.tar.gz
gentoo-8c6efa4aaba7b6f438ac18ec60f03e533a6f14f3.tar.bz2
gentoo-8c6efa4aaba7b6f438ac18ec60f03e533a6f14f3.zip
dev-python/pipx: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pipx')
-rw-r--r--dev-python/pipx/Manifest1
-rw-r--r--dev-python/pipx/pipx-1.4.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pipx/Manifest b/dev-python/pipx/Manifest
index 4f03cfde56f4..f37c63a05478 100644
--- a/dev-python/pipx/Manifest
+++ b/dev-python/pipx/Manifest
@@ -1 +1,2 @@
DIST pipx-1.3.3.gh.tar.gz 355893 BLAKE2B f2ae8847d4c6f2205fe75a47df04afb49d57cc8f717cc615d5201f54bd2dee2940bc095a778496cd7baf048df8db8e74ca7ff5a7ee3b2024bf37f27bbeb425eb SHA512 42246a0d8275beee16b85a1007d46d328a892beb89e79fb406ba53942a57b7312d34150376835395b9eca3ecb68db71f0c3c470fd92519dd9175311003707a3d
+DIST pipx-1.4.0.gh.tar.gz 357942 BLAKE2B 34b0ede5a5160c8a5fcdff81c4902e0119041e7740b165c3a384234ba8362fa95db8002778a8987b4f93d9bd132152868171bb1627987c4cb7f4eb1cf2e4cc84 SHA512 5a0cd494ed6a4faa3f9f5cc5c56ee8ce9f27b3a456ad2eed2eaf5a9d175ea97209b2ec7b95e1500e1126ec066660f344f942692916cef552c39f49b2669160c9
diff --git a/dev-python/pipx/pipx-1.4.0.ebuild b/dev-python/pipx/pipx-1.4.0.ebuild
new file mode 100644
index 000000000000..ff6c65c37339
--- /dev/null
+++ b/dev-python/pipx/pipx-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Install and Run Python Applications in Isolated Environments"
+HOMEPAGE="
+ https://pipx.pypa.io/stable/
+ https://pypi.org/project/pipx/
+ https://github.com/pypa/pipx/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/pypa/pipx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/userpath-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest --net-pypiserver
+}