summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-15 20:19:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-15 21:39:45 +0200
commit5ef338d0850f3d63d9f13cb5a3b34e6fd42063db (patch)
tree8b7567f57a9686055b5d51904c4f7f5455921a95 /dev-python/pip-run
parentdev-python/importlib_metadata: Bump to 6.4.1 (diff)
downloadgentoo-5ef338d0850f3d63d9f13cb5a3b34e6fd42063db.tar.gz
gentoo-5ef338d0850f3d63d9f13cb5a3b34e6fd42063db.tar.bz2
gentoo-5ef338d0850f3d63d9f13cb5a3b34e6fd42063db.zip
dev-python/pip-run: Bump to 10.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-10.0.7.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index a3e1ff912d4e..05678f5745c1 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1 +1,2 @@
DIST pip-run-10.0.5.tar.gz 32411 BLAKE2B ce633d003fa869f199dfdded46efb6bfa9fc4e24327cb99b0176d8e6e6bcff552c6f84589b77907a063fba3315b3f9c64d6c182d70dc39d59a1342ee9fe62193 SHA512 55309445793c101d54fd61303e770ae271cfe2be20e7bc084ca0f4e6363a8de28ffdd7cd1b8c595c88d5c0a99863182053d00d3a4175fa5465ef958401601d66
+DIST pip-run-10.0.7.tar.gz 32869 BLAKE2B ea5dfea09def536eced9436a114f12cbefccf26c4b37376a560dc1fffdd8167d019ec52d57666d7b4d77dc9c580a5f48455d945aa9ddb4340a7dca88f0ded309 SHA512 cd8780372f579005e40c77b3c2d9e582cd1a144e871eec205fd0bd2ff64eac837918211d3479088f56bd3043dbfd883502b2d6f7b01dc24448888f65fdd6920b
diff --git a/dev-python/pip-run/pip-run-10.0.7.ebuild b/dev-python/pip-run/pip-run-10.0.7.ebuild
new file mode 100644
index 000000000000..d9897d60ee5f
--- /dev/null
+++ b/dev-python/pip-run/pip-run-10.0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' 3.8)
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_scripts.py
+ )
+ fi
+
+ epytest -m "not network"
+}