summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 22:42:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 23:00:00 +0200
commitd2b6505c7b356363e5aa0b8c3121d88f44b55979 (patch)
tree7114804b4c7e776116da9e0c297eff77d8122504 /dev-python/pillow
parentapp-admin/awscli: Bump to 1.20.35 (diff)
downloadgentoo-d2b6505c7b356363e5aa0b8c3121d88f44b55979.tar.gz
gentoo-d2b6505c7b356363e5aa0b8c3121d88f44b55979.tar.bz2
gentoo-d2b6505c7b356363e5aa0b8c3121d88f44b55979.zip
dev-python/pillow: Bump to 8.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-8.3.2.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 45381c8172e1..db526aeefeee 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,3 +1,4 @@
DIST pillow-8.2.0.tar.gz 47898485 BLAKE2B bd8421a101e0be080f2fab238c3c26a4e1e722738e1036bfbb533f420881ea638016ac56e9e66ec74a93c6dafc6e4f8807ec3d504400bb675488da00c9c3cb1c SHA512 40e97a54689ca04349d17b69b0e95bb3ef4fde0b60c6c55a2ec76034a5c2a9ebee0b310f68de1636db08786d9b2ad444bf10ac3b42a31404847cc165aa8392ac
DIST pillow-8.3.0.tar.gz 48543291 BLAKE2B f74f2576e3f906db3c96f0854dcc3d7d5d0248b1e35d32da5f88e41751068012e64fed134f34263e2b244263f655fb2602d00d8d191c04573a93164a2fcc7c22 SHA512 ad0f9c50d1dbaaef56fdc43d6b4fa0960453bb0bf60bcafcc33bdbd8e5b4d698e4690baf1ec6be56651153fdbf5af520e9bbd8367a75fe36a995baac47069b4d
DIST pillow-8.3.1.tar.gz 48722889 BLAKE2B 4483c3cebda33e57f665a7a73b5898b4f0fb5be895ec05feeb266a99f33c78fd1b550d82225c201ea015d267206f5b47909b4963da9f17d51d0e5bd897332a77 SHA512 22a85a5510c8ec13928af571ec7f329f4728c46ebaadfe338d837f6d3718eedb57b7548fd9a3260a3bb0c0f97b3f3c911e730af01f90ca70c967d44b1e5d3606
+DIST pillow-8.3.2.tar.gz 48783084 BLAKE2B c63930df3af0270bb092841b3c39a1ea75343ee743f9e4b083a2f6f621ad1e58c7c04c5d6cf4b648fbef2d79d7b5258e27d220cd32dbfff592b5ca70d1f28d64 SHA512 668e97abcd36e42dafa433e8814a0106fe742ab093b12748c13dd9f3f872d18f8b9d44c1a8d4115aa87969a98b53c36ae4783cc3804e2d9a1249eef300555c88
diff --git a/dev-python/pillow/pillow-8.3.2.ebuild b/dev-python/pillow/pillow-8.3.2.ebuild
new file mode 100644
index 000000000000..2dfcbf90d074
--- /dev/null
+++ b/dev-python/pillow/pillow-8.3.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant +jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg jpeg2k tiff )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:0 )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:0= )"
+RDEPEND="${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[png]
+ )
+ )
+"
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ DISTUTILS_ARGS=(
+ build_ext
+ --disable-platform-guessing
+ $(use_enable truetype freetype)
+ $(use_enable jpeg)
+ $(use_enable jpeg2k jpeg2000)
+ $(use_enable lcms)
+ $(use_enable tiff)
+ $(use_enable imagequant)
+ $(use_enable webp)
+ $(use_enable webp webpmux)
+ $(use_enable xcb)
+ $(use_enable zlib)
+ )
+
+ # setup.py sucks at adding the right toolchain paths but it does
+ # accept additional ones from INCLUDE and LIB so set these. You
+ # wouldn't normally need these at all as the toolchain should look
+ # here anyway but this setup.py does stupid things.
+ export \
+ INCLUDE=${ESYSROOT}/usr/include \
+ LIB=${ESYSROOT}/usr/$(get_libdir)
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ virtx epytest -p no:relaxed
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}