summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 06:40:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 07:14:49 +0200
commit8990a51195b52fa804719ac642536518d7907cb2 (patch)
treed30620cec2c9ae58e56ba156b7733556a608a932 /dev-python/pikepdf
parentdev-python/stevedore: Bump to 4.1.0 (diff)
downloadgentoo-8990a51195b52fa804719ac642536518d7907cb2.tar.gz
gentoo-8990a51195b52fa804719ac642536518d7907cb2.tar.bz2
gentoo-8990a51195b52fa804719ac642536518d7907cb2.zip
dev-python/pikepdf: Bump to 6.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-6.2.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index afe3953d8f09..746301f54a23 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -2,3 +2,4 @@ DIST pikepdf-5.6.1.gh.tar.gz 2905150 BLAKE2B 35c06251debb935b88f13e27f42f80b3627
DIST pikepdf-6.0.2.gh.tar.gz 2905158 BLAKE2B b80bee6690513ebd43b590ec5addb40f81a31b27adab77e04f0fd521e0a23a5bc974c6026163f1c9faf23f0d9e2b004961d93a19fab20a43bdf27b0a69597413 SHA512 8c1213535d503f388de6845d28f430947630717f8c299e6a384204de38e2f5f1a5858a0307abd5a34a2f4d79787bdab0e1be286a99ce91b64fc0fcf3f3553d89
DIST pikepdf-6.1.0.gh.tar.gz 2905226 BLAKE2B efa6ce6d75e36885f6b59eb01a869c50ba4eddae4d7c10bdfb13d1c8162a6f21a51d4b4fa3d3d0d80180d72c558a245aadf4fa372993efcdf735c5a4a7a64a35 SHA512 75349634a97fed40dc8f86ad58c4e45cccf3e6e78818d473894c6bc52a3a5584f4f705836fab038e8256b44b7d02801d3e7202488366b8ba298972fa6f0ef809
DIST pikepdf-6.2.0.gh.tar.gz 2905445 BLAKE2B 07a6ade367c438ab5df885827d7610e998252d1c8784b1f81d377c2d3ac897a812802a6ed1b8e84cedeb6fc8394e2e77116e2628c31ae06d3b08a8ca6957b25f SHA512 3287ed2203b8dc1c2f5281a45612cfda3107576413d4579984b9e7f6a5bcdbb795bf09559b4ca8a4fe5d7f70d94f5c404b4e3f6422bdfde4b8fd48830c1e280d
+DIST pikepdf-6.2.1.gh.tar.gz 2905482 BLAKE2B 9a5b2c7a1b23f4156b89b44780e98f2a82582c05221c0ec2ead3490f3a14a6fa34caea000fb34c0df1458d8aac019bbb0bce10bbbf8bba0c159639b3129e597c SHA512 f6888dcd42c18377f69aa71fce92aa752b73f369e2db4afc106b2b345556a3a9efbb007101066d562f44cfed0bb5816ae0a6cd998b1d634555bf27fbe94baddf
diff --git a/dev-python/pikepdf/pikepdf-6.2.1.ebuild b/dev-python/pikepdf/pikepdf-6.2.1.ebuild
new file mode 100644
index 000000000000..2f94f1d1f970
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-6.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="
+ https://github.com/pikepdf/pikepdf/
+ https://pypi.org/project/pikepdf/
+"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=app-text/qpdf-11.1.1:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/-n auto/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}