summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pastescript
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/Manifest1
-rw-r--r--dev-python/pastescript/files/pastescript-setup.py-exclude-tests.patch19
-rw-r--r--dev-python/pastescript/metadata.xml8
-rw-r--r--dev-python/pastescript/pastescript-2.0.2.ebuild57
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/pastescript/Manifest b/dev-python/pastescript/Manifest
new file mode 100644
index 000000000000..14429e6a55df
--- /dev/null
+++ b/dev-python/pastescript/Manifest
@@ -0,0 +1 @@
+DIST PasteScript-2.0.2.tar.gz 117521 SHA256 c03f249805538cc2328741ae8d262a9200ae1c993119b3d9bac4cd422cb476c0 SHA512 2f093eb982972fed354219c75c2e008931cea553960cea8aaafbe57cde8556de5626e7eb9bb3b9b7328bad3b7d9899f11fc9773a65380396dae506e7531516de WHIRLPOOL 951c16499bb9e120813749871cfdc7b36b04660c4dbb4c0d2c7335312a8b58c412dc0ca49029ce674be90207645eb1657bde8ae869ffb72d29c592ca978cdca9
diff --git a/dev-python/pastescript/files/pastescript-setup.py-exclude-tests.patch b/dev-python/pastescript/files/pastescript-setup.py-exclude-tests.patch
new file mode 100644
index 000000000000..24190a783f06
--- /dev/null
+++ b/dev-python/pastescript/files/pastescript-setup.py-exclude-tests.patch
@@ -0,0 +1,19 @@
+# HG changeset patch
+# User Mike Gilbert <floppym@gentoo.org>
+# Date 1353179174 18000
+# Node ID 814fbc493e7a9999086127f64c2406ecb1794990
+# Parent 510ff7d7627750eb0dbbc0d36fa63c72ffa6b303
+Exclude subpackages of tests.
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -61,7 +61,7 @@
+ url="http://pythonpaste.org/script/",
+ namespace_packages=['paste'],
+ license='MIT',
+- packages=find_packages(exclude='tests'),
++ packages=find_packages(exclude=['tests','tests.*']),
+ package_data={
+ 'paste.script': ['paster-templates/basic_package/setup.*',
+ 'paster-templates/basic_package/tests/*.py',
diff --git a/dev-python/pastescript/metadata.xml b/dev-python/pastescript/metadata.xml
new file mode 100644
index 000000000000..6b387078e551
--- /dev/null
+++ b/dev-python/pastescript/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">PasteScript</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pastescript/pastescript-2.0.2.ebuild b/dev-python/pastescript/pastescript-2.0.2.ebuild
new file mode 100644
index 000000000000..f583a86f8880
--- /dev/null
+++ b/dev-python/pastescript/pastescript-2.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+MY_PN="PasteScript"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
+HOMEPAGE="http://pythonpaste.org/script/ http://pypi.python.org/pypi/PasteScript"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/paste-1.3[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests are broken.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ nosetests -v -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ cd "${BUILD_DIR}"/sphinx/html || die
+ dohtml -r [a-z]* _static
+ fi
+}