summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-29 21:24:22 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-29 21:40:14 +0300
commite6e9a32c1d2246c48c8c650a866090060b5251cd (patch)
treee6ff78617c5c0c885a4641bdaf90a46e460dcd56 /dev-python/owslib
parentdev-python/pygit2: add 1.10.1 (diff)
downloadgentoo-e6e9a32c1d2246c48c8c650a866090060b5251cd.tar.gz
gentoo-e6e9a32c1d2246c48c8c650a866090060b5251cd.tar.bz2
gentoo-e6e9a32c1d2246c48c8c650a866090060b5251cd.zip
dev-python/owslib: add 0.27.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/owslib')
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.27.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index d9a4945dbb3d..fb40bac9e68f 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1 +1,2 @@
DIST owslib-0.26.0.gh.tar.gz 948463 BLAKE2B 2cbdad2d8e9bc4b8a7e2db58dc75a7c053bde0b2cc772a01f230db044909615b96e62b08bb93233df153686a180a5e93af1bda6ea79b8565efacccfa18fcf4da SHA512 27362c47eae87dc6318d505dd1b0987de36d140d2d0fd5d7a5195470de39d73807fbcafa142366f6981cc36453c262a41133c6c68baf45a97d0fdaae5a0ebf4b
+DIST owslib-0.27.2.gh.tar.gz 949148 BLAKE2B 2e12b43de3c3c362b03af15c93fe268e9ad8dd8647a18a8ef978203db896db65dd26cd20d6d58214880248593589604f764887b50c9eb8695d8e51accef3dfe8 SHA512 02c70731ef92783d53b8f0dff2cec7d28d14ac08b0a4b5090183f9eacf156d539c823fcd2ae480c07447e901697de498cdf2aaf27c8b6d46fa4cf8eb3679ceee
diff --git a/dev-python/owslib/owslib-0.27.2.ebuild b/dev-python/owslib/owslib-0.27.2.ebuild
new file mode 100644
index 000000000000..d33d496120be
--- /dev/null
+++ b/dev-python/owslib/owslib-0.27.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib/"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/OWSLib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/pillow[${PYTHON_USEDEP}] )"
+
+EPYTEST_DESELECT=(
+ tests/test_ogcapi_features_pygeoapi.py::test_ogcapi_features_pygeoapi
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i tox.ini || die
+ distutils-r1_src_prepare
+}