summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-18 07:11:23 +0100
committerSam James <sam@gentoo.org>2023-09-18 07:11:39 +0100
commit18f4949ab453e5ba986d55461841e3a5c138925a (patch)
treea709a61d07f79b15455d0dc29d4ef0838716299e /dev-python/numpy
parentnet-vpn/libreswan: drop 4.11 (diff)
downloadgentoo-18f4949ab453e5ba986d55461841e3a5c138925a.tar.gz
gentoo-18f4949ab453e5ba986d55461841e3a5c138925a.tar.bz2
gentoo-18f4949ab453e5ba986d55461841e3a5c138925a.zip
dev-python/numpy: wire up noblas option, default enable lapack/blas
+lapack because the internal fallbacks are pretty slow. Building without blas is barely supported anyway, see bug #914358. Closes: https://bugs.gentoo.org/914358 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-1.26.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/numpy/numpy-1.26.0.ebuild b/dev-python/numpy/numpy-1.26.0.ebuild
index bc6646bd3079..49c3b34adb9c 100644
--- a/dev-python/numpy/numpy-1.26.0.ebuild
+++ b/dev-python/numpy/numpy-1.26.0.ebuild
@@ -20,7 +20,9 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-IUSE="lapack"
+# +lapack because the internal fallbacks are pretty slow. Building without blas
+# is barely supported anyway, see bug #914358.
+IUSE="+lapack"
if [[ ${PV} != *_[rab]* ]] ; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
@@ -59,6 +61,7 @@ python_prepare_all() {
python_configure_all() {
DISTUTILS_ARGS=(
+ -Dallow-noblas=$(usex !lapack true false)
-Dblas=$(usev lapack cblas)
-Dlapack=$(usev lapack lapack)
# TODO: cpu-* options