summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 09:13:18 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 09:45:41 +0100
commitca37d7c0b4d5702f5c1fa92206fa5af1a850f1c4 (patch)
tree8bf466d9a5943051c16eb70431572ab560c58282 /dev-python/nose
parentdev-python/nose: Remove the live ebuild (diff)
downloadgentoo-ca37d7c0b4d5702f5c1fa92206fa5af1a850f1c4.tar.gz
gentoo-ca37d7c0b4d5702f5c1fa92206fa5af1a850f1c4.tar.bz2
gentoo-ca37d7c0b4d5702f5c1fa92206fa5af1a850f1c4.zip
dev-python/nose: Make coverage optional, EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/metadata.xml4
-rw-r--r--dev-python/nose/nose-1.3.7-r4.ebuild98
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/nose/metadata.xml b/dev-python/nose/metadata.xml
index 13648a4f19f0..a92a97fc50db 100644
--- a/dev-python/nose/metadata.xml
+++ b/dev-python/nose/metadata.xml
@@ -9,4 +9,8 @@
<remote-id type="pypi">nose</remote-id>
<remote-id type="github">nose-devs/nose</remote-id>
</upstream>
+ <use>
+ <flag name="coverage">Pull in <pkg>dev-python/coverage</pkg> needed
+ for nose-xcover plugin.</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-python/nose/nose-1.3.7-r4.ebuild b/dev-python/nose/nose-1.3.7-r4.ebuild
new file mode 100644
index 000000000000..fdbf207e5028
--- /dev/null
+++ b/dev-python/nose/nose-1.3.7-r4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
+HOMEPAGE="
+ https://pypi.org/project/nose/
+ https://nose.readthedocs.io/en/latest/
+ https://github.com/nose-devs/nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="coverage doc examples test"
+
+REQUIRED_USE="
+ doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7 python3_{5,6})
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.5-backport.patch
+
+ # Patch against master found in an upstream PR, backported:
+ # https://github.com/nose-devs/nose/pull/1004
+ "${FILESDIR}"/${P}-coverage-4.1-support.patch
+
+ "${FILESDIR}"/${P}-python-3.6-test.patch
+)
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Tests need to be converted, and they don't respect BUILD_DIR.
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_resolve/_&/g" \
+ -e "s/test_raises_bad_return/_&/g" \
+ -e "s/test_raises_twisted_error/_&/g" \
+ -i unit_tests/test_twisted.py || die "sed failed"
+ # Disable versioning of nosetests script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
+ -i setup.py || die "sed2 failed"
+
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local add_targets=()
+
+ if use test; then
+ add_targets+=( egg_info )
+ python_is_python3 && add_targets+=( build_tests )
+ fi
+
+ distutils-r1_python_compile ${add_targets[@]}
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && HTML_DOCS=( doc/.build/html/. )
+ distutils-r1_python_install_all
+}