summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-05 04:24:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-05 04:55:19 +0100
commit2c445fb98ccaa4281b3014ecd0670ed43007b98d (patch)
treeaec67a9f5230da0721d81ec49b6fd8ffca52d395 /dev-python/netcdf4
parentdev-python/fsspec: Bump to 2023.3.0 (diff)
downloadgentoo-2c445fb98ccaa4281b3014ecd0670ed43007b98d.tar.gz
gentoo-2c445fb98ccaa4281b3014ecd0670ed43007b98d.tar.bz2
gentoo-2c445fb98ccaa4281b3014ecd0670ed43007b98d.zip
Rename dev-python/{netcdf4-python → netcdf4}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/netcdf4')
-rw-r--r--dev-python/netcdf4/Manifest1
-rw-r--r--dev-python/netcdf4/metadata.xml22
-rw-r--r--dev-python/netcdf4/netcdf4-1.5.8.ebuild47
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/netcdf4/Manifest b/dev-python/netcdf4/Manifest
new file mode 100644
index 000000000000..a1ee1d79e762
--- /dev/null
+++ b/dev-python/netcdf4/Manifest
@@ -0,0 +1 @@
+DIST netCDF4-1.5.8.tar.gz 767013 BLAKE2B 26e30b9ef74b6d1af07fadc5a0c93c1370c9e684b69345e18801c00691362766bce393b7fc8c0ccd4cd4b8e7ac448f3c69a1769e056c780c668c441cf0418b94 SHA512 b43e10356a60ecdd1aaa7585648242e9d610e042da8fd97f374617d7813cc9f35b4133a88ac4c10e921df12d5b2f2b1668af4fb69578b57b7c3d57a731579260
diff --git a/dev-python/netcdf4/metadata.xml b/dev-python/netcdf4/metadata.xml
new file mode 100644
index 000000000000..e9799992da68
--- /dev/null
+++ b/dev-python/netcdf4/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ netcdf4-python is a Python interface to the netCDF C library.
+ netCDF version 4 can read and write files in both the new netCDF 4
+ and the old netCDF 3 format, and can create files that are readable
+ by HDF5 clients. The API modelled after Scientific.IO.NetCDF, and
+ should be familiar to users of that module.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">netCDF4</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/netcdf4/netcdf4-1.5.8.ebuild b/dev-python/netcdf4/netcdf4-1.5.8.ebuild
new file mode 100644
index 000000000000..25f2870753da
--- /dev/null
+++ b/dev-python/netcdf4/netcdf4-1.5.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 optfeature
+
+MY_PN="netCDF4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python/numpy interface to the netCDF C library"
+HOMEPAGE="https://unidata.github.io/netcdf4-python/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sci-libs/hdf5
+ sci-libs/netcdf:=[hdf5]"
+RDEPEND="${DEPEND}
+ dev-python/cftime[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ sci-libs/hdf5
+ sci-libs/netcdf[hdf5,tools]
+ dev-python/cftime[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ local -x NO_NET=1
+ cd test || die
+ "${EPYTHON}" run_all.py || die
+}
+
+pkg_postinst() {
+ optfeature "HDF4 support" sci-libs/hdf "sci-libs/netcdf[hdf]"
+ optfeature "MPI parallel IO support" "sci-libs/hdf5[mpi]" "sci-libs/netcdf[mpi]"
+ optfeature "OPeNDAP support" net-misc/curl "sci-libs/netcdf[dap]"
+}