summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-18 06:05:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-18 06:26:30 +0200
commit0d6352641e1d1c52b149578e58f8738d202ec653 (patch)
tree898fd7ea8fd33bbf52fd47a4f709c7267a808770 /dev-python/netcdf4
parentdev-python/urllib3: Bump to 2.2.2 (diff)
downloadgentoo-0d6352641e1d1c52b149578e58f8738d202ec653.tar.gz
gentoo-0d6352641e1d1c52b149578e58f8738d202ec653.tar.bz2
gentoo-0d6352641e1d1c52b149578e58f8738d202ec653.zip
dev-python/netcdf4: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/netcdf4')
-rw-r--r--dev-python/netcdf4/Manifest1
-rw-r--r--dev-python/netcdf4/netcdf4-1.7.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/netcdf4/Manifest b/dev-python/netcdf4/Manifest
index 50cfaf9101f5..4bfb7a2252a8 100644
--- a/dev-python/netcdf4/Manifest
+++ b/dev-python/netcdf4/Manifest
@@ -1 +1,2 @@
DIST netCDF4-1.6.5.tar.gz 764969 BLAKE2B 6337099fbb66a53f2cda7a39e1b0dbb7b3ab9e6ec04177fc0deca1c86003bc20d9ed5d6ba72d5917766c1b9784c39c7cff328a7b5494aeb46bcc1ac895c13e7c SHA512 10f9b62399cf2d155f44b56d6d0f15950f610e855755bcb6d7d1756ded9ed513e83677ab70f7bc75eaffaca1703f37cc0a48c565927df7eb67beeb5a0be6f8d0
+DIST netcdf4-1.7.1.tar.gz 827831 BLAKE2B a0b6956be7749133f4823f385ea82b84975985814b90e7172ecbfb6d4590cf0809471672375a2331181735d7af622f6302adf2dad5fd95f09e24078bbdc20581 SHA512 69b7465f1d7b138b9f2f18732528207c7a573e0a5637c964a881fddc8f01a53b16c7250c22824a6ee0e3383dccd7f93b1971f95a9d1558d6088709efa7558ce7
diff --git a/dev-python/netcdf4/netcdf4-1.7.1.ebuild b/dev-python/netcdf4/netcdf4-1.7.1.ebuild
new file mode 100644
index 000000000000..686805676544
--- /dev/null
+++ b/dev-python/netcdf4/netcdf4-1.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=netCDF4
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python/numpy interface to the netCDF C library"
+HOMEPAGE="
+ https://unidata.github.io/netcdf4-python/
+ https://github.com/unidata/netcdf4-python/
+ https://pypi.org/project/netCDF4/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/hdf5:=
+ sci-libs/netcdf:=[hdf5]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/cftime[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+ sci-libs/netcdf[tools(+)]
+ )
+"
+
+python_test() {
+ local -x NO_NET=1
+ cd test || die
+ "${EPYTHON}" run_all.py || die
+}
+
+pkg_postinst() {
+ optfeature "HDF4 support" sci-libs/hdf "sci-libs/netcdf[hdf]"
+ optfeature "MPI parallel IO support" "sci-libs/hdf5[mpi]" "sci-libs/netcdf[mpi]"
+ optfeature "OPeNDAP support" net-misc/curl "sci-libs/netcdf[dap]"
+}