summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-26 04:50:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-26 04:52:04 +0200
commit01190951eed5454b73072e858918565498f83cc7 (patch)
tree5c4e500c369bd6fe93aca89eb3dc954f45eb23a6 /dev-python/netcdf4
parentdev-python/pyproject-fmt: Bump to 1.3.0 (diff)
downloadgentoo-01190951eed5454b73072e858918565498f83cc7.tar.gz
gentoo-01190951eed5454b73072e858918565498f83cc7.tar.bz2
gentoo-01190951eed5454b73072e858918565498f83cc7.zip
dev-python/netcdf4: Bump to 1.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/netcdf4')
-rw-r--r--dev-python/netcdf4/Manifest1
-rw-r--r--dev-python/netcdf4/netcdf4-1.6.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/netcdf4/Manifest b/dev-python/netcdf4/Manifest
index c2fb53876e7f..2dc9fb375fab 100644
--- a/dev-python/netcdf4/Manifest
+++ b/dev-python/netcdf4/Manifest
@@ -1 +1,2 @@
DIST netCDF4-1.6.4.tar.gz 778542 BLAKE2B fb90aa5c990a5cb71b82ba0d5bfc39014d552d0804eee24daf7111fc19023b07c3af76e913e227595825748e599eb3c8425f336fa2b520c6a6ae4155e73c2d64 SHA512 a3582fcdd4978d8faa9fd7b49ec40cba0e4d56a32a283f18e1133a1a5ba6e89406625390cbebd0c162d31c65c63060cd8cc4398f0eee3c45be43b54016ec0f48
+DIST netCDF4-1.6.5.tar.gz 764969 BLAKE2B 6337099fbb66a53f2cda7a39e1b0dbb7b3ab9e6ec04177fc0deca1c86003bc20d9ed5d6ba72d5917766c1b9784c39c7cff328a7b5494aeb46bcc1ac895c13e7c SHA512 10f9b62399cf2d155f44b56d6d0f15950f610e855755bcb6d7d1756ded9ed513e83677ab70f7bc75eaffaca1703f37cc0a48c565927df7eb67beeb5a0be6f8d0
diff --git a/dev-python/netcdf4/netcdf4-1.6.5.ebuild b/dev-python/netcdf4/netcdf4-1.6.5.ebuild
new file mode 100644
index 000000000000..a17a67cb13e8
--- /dev/null
+++ b/dev-python/netcdf4/netcdf4-1.6.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=netCDF4
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python/numpy interface to the netCDF C library"
+HOMEPAGE="
+ https://unidata.github.io/netcdf4-python/
+ https://github.com/unidata/netcdf4-python/
+ https://pypi.org/project/netCDF4/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/hdf5:=
+ sci-libs/netcdf:=[hdf5]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/cftime[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+ sci-libs/netcdf[tools(+)]
+ )
+"
+
+python_test() {
+ local -x NO_NET=1
+ cd test || die
+ "${EPYTHON}" run_all.py || die
+}
+
+pkg_postinst() {
+ optfeature "HDF4 support" sci-libs/hdf "sci-libs/netcdf[hdf]"
+ optfeature "MPI parallel IO support" "sci-libs/hdf5[mpi]" "sci-libs/netcdf[mpi]"
+ optfeature "OPeNDAP support" net-misc/curl "sci-libs/netcdf[dap]"
+}