summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-01 02:11:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-01 02:29:38 +0100
commit5b5a2293bef1998ae7f10ba722616a4d1c92948e (patch)
tree6bba85c0eaddec8ab6922b67422a76d62c8625fd /dev-python/nbsphinx
parentdev-python/astroid: Bump to 2.9.1 (diff)
downloadgentoo-5b5a2293bef1998ae7f10ba722616a4d1c92948e.tar.gz
gentoo-5b5a2293bef1998ae7f10ba722616a4d1c92948e.tar.bz2
gentoo-5b5a2293bef1998ae7f10ba722616a4d1c92948e.zip
dev-python/nbsphinx: Bump to 0.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbsphinx')
-rw-r--r--dev-python/nbsphinx/Manifest1
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.8.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index 4a12a4e1ad28..cc00a89c75d3 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1 +1,2 @@
DIST nbsphinx-0.8.7.tar.gz 146388 BLAKE2B 28149728b95403236bfe601aa2190f2262069466e6a82e688640b3e085e8f03800199e1f6c5f1a321594a1a6bbf73a2906b0f4cdf2bcf4b5e781fe7bb4fa917e SHA512 01b8d3095fefc32301ed608916bdeeb469bb180709d1512178f8ca2e29f4404f48607c1fc1ec0700ee2aa745cbdef350edda0f06f2dd464d10c020dc38774778
+DIST nbsphinx-0.8.8.tar.gz 146831 BLAKE2B 26687d74900e7667dff644a91d58eeed57e2b2e91391d4a8024d5ee2c858d5d8bb132db5b025357817004480bc161d8ad6f5c003240d6bbc23420e1633a63abd SHA512 8a791171d6fffc414e19224d29e323644e141c5c51522b7914549aa066f2757cb4e88318a1bf20e4abbd7130cf85c4e8c3fb5537802098342a32c896e3caf3bf
diff --git a/dev-python/nbsphinx/nbsphinx-0.8.8.ebuild b/dev-python/nbsphinx/nbsphinx-0.8.8.ebuild
new file mode 100644
index 000000000000..f06b11cfd645
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.8.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]"